summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-14 07:39:10 +0000
committerJohn Crispin <john@openwrt.org>2015-07-14 07:39:10 +0000
commit2de791010247a33b38ab05bd6fbfb6ef72c13578 (patch)
treec7f86d2602b42da542e893b2f7c966576892a69e /target/linux/brcm2708/Makefile
parent1b7379689525ef0ada52035c4461acf7e7e4921c (diff)
downloadmaster-31e0f0ae-2de791010247a33b38ab05bd6fbfb6ef72c13578.tar.gz
master-31e0f0ae-2de791010247a33b38ab05bd6fbfb6ef72c13578.tar.bz2
master-31e0f0ae-2de791010247a33b38ab05bd6fbfb6ef72c13578.zip
brcm2708: Implement sysupgrade
Implement sysupgrade for Raspberry Pi, similar to the way it is done on x86: The config files are saved in the boot partition and moved to where they are normally expected in preinit. Also add optional gzip compression for the SD card image, since this can save a lot of space (76M vs 6M), also similar to x86. Signed-off-by: Bruno Randolf <br1@einfach.org> SVN-Revision: 46347
Diffstat (limited to 'target/linux/brcm2708/Makefile')
-rw-r--r--target/linux/brcm2708/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
index 30f6e1dfa4..015aa9c2a8 100644
--- a/target/linux/brcm2708/Makefile
+++ b/target/linux/brcm2708/Makefile
@@ -19,7 +19,7 @@ SUBTARGETS:=bcm2708 bcm2709
KERNEL_PATCHVER:=3.18
include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
+DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
define Target/Description
Build firmware image for Broadcom BCM2708/BCM2709 SoC devices.