summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm-2.6
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
committerTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
commit03beb39e5f76f6361adc99244afb4d274310d158 (patch)
treead51f5b31163969f63c468720c0ac606bf0fe17e /target/linux/brcm-2.6
parentfa859ea32a7d0775e426b80757b37c09e3e2282c (diff)
downloadmaster-31e0f0ae-03beb39e5f76f6361adc99244afb4d274310d158.tar.gz
master-31e0f0ae-03beb39e5f76f6361adc99244afb4d274310d158.tar.bz2
master-31e0f0ae-03beb39e5f76f6361adc99244afb4d274310d158.zip
split out profile definitions from Makefiles
structure is as follows: target/linux/<arch>/profiles/<profilename>.mk These files are included by a blob match in the target Makefile The files should be labeled based on their profile Name in the definition SVN-Revision: 6468
Diffstat (limited to 'target/linux/brcm-2.6')
-rw-r--r--target/linux/brcm-2.6/Makefile31
-rw-r--r--target/linux/brcm-2.6/profiles/Atheros.mk17
-rw-r--r--target/linux/brcm-2.6/profiles/None.mk17
-rw-r--r--target/linux/brcm-2.6/profiles/WGT634U.mk17
4 files changed, 53 insertions, 29 deletions
diff --git a/target/linux/brcm-2.6/Makefile b/target/linux/brcm-2.6/Makefile
index 8b135072c3..a34d2187ae 100644
--- a/target/linux/brcm-2.6/Makefile
+++ b/target/linux/brcm-2.6/Makefile
@@ -19,34 +19,7 @@ endef
include $(INCLUDE_DIR)/kernel-build.mk
DEFAULT_PACKAGES += kmod-switch kmod-diag
-define Profile/Atheros
- NAME:=Atheros WiFi (default)
- PACKAGES:=kmod-madwifi
-endef
-
-define Profile/Atheros/Description
- Package set compatible with hardware using Atheros WiFi cards
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/WGT634U
- NAME:=Netgear WGT634U
- PACKAGES:=kmod-madwifi kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/WGT634U/Description
- Package set compatible with the Netgear WGT634U. Contains USB support
-endef
-$(eval $(call Profile,WGT634U))
-
-define Profile/None
- NAME:=No WiFi
- PACKAGES:=
-endef
-
-define Profile/None/Description
- Package set without WiFi support
-endef
-$(eval $(call Profile,None))
+# include the profiles
+-include profiles/*.mk
$(eval $(call BuildKernel))
diff --git a/target/linux/brcm-2.6/profiles/Atheros.mk b/target/linux/brcm-2.6/profiles/Atheros.mk
new file mode 100644
index 0000000000..029586848f
--- /dev/null
+++ b/target/linux/brcm-2.6/profiles/Atheros.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-madwifi
+endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/brcm-2.6/profiles/None.mk b/target/linux/brcm-2.6/profiles/None.mk
new file mode 100644
index 0000000000..2fcfacde9f
--- /dev/null
+++ b/target/linux/brcm-2.6/profiles/None.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+ NAME:=No WiFi
+ PACKAGES:=
+endef
+
+define Profile/None/Description
+ Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+
diff --git a/target/linux/brcm-2.6/profiles/WGT634U.mk b/target/linux/brcm-2.6/profiles/WGT634U.mk
new file mode 100644
index 0000000000..2a81e3ae13
--- /dev/null
+++ b/target/linux/brcm-2.6/profiles/WGT634U.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WGT634U
+ NAME:=Netgear WGT634U
+ PACKAGES:=kmod-madwifi kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/WGT634U/Description
+ Package set compatible with the Netgear WGT634U. Contains USB support
+endef
+$(eval $(call Profile,WGT634U))
+