summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm-2.4/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-16 03:11:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-16 03:11:17 +0000
commitbf0dd24627877a7a5bc71a8408678cedbd78583c (patch)
tree44f981976a62a86972d9538d35ccac933c221664 /target/linux/brcm-2.4/image
parente3ecefbd23d297ed659422db4b9a886dbfebbdca (diff)
downloadmaster-31e0f0ae-bf0dd24627877a7a5bc71a8408678cedbd78583c.tar.gz
master-31e0f0ae-bf0dd24627877a7a5bc71a8408678cedbd78583c.tar.bz2
master-31e0f0ae-bf0dd24627877a7a5bc71a8408678cedbd78583c.zip
create broadcom initramfs images and move the lzma decompressor area a bit further
SVN-Revision: 9556
Diffstat (limited to 'target/linux/brcm-2.4/image')
-rw-r--r--target/linux/brcm-2.4/image/Makefile4
-rw-r--r--target/linux/brcm-2.4/image/lzma-loader/src/Makefile2
2 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/brcm-2.4/image/Makefile b/target/linux/brcm-2.4/image/Makefile
index 51975fe702..11192935cb 100644
--- a/target/linux/brcm-2.4/image/Makefile
+++ b/target/linux/brcm-2.4/image/Makefile
@@ -78,6 +78,10 @@ define Image/Build/squashfs
$(call Image/Build/jffs2-128k,$(1))
endef
+define Image/Build/Initramfs
+ $(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-initramfs.trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma
+endef
+
define Image/Build
$(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1),$(1))
$(call Image/Build/$(1),$(1))
diff --git a/target/linux/brcm-2.4/image/lzma-loader/src/Makefile b/target/linux/brcm-2.4/image/lzma-loader/src/Makefile
index 85a864674b..3320e565d0 100644
--- a/target/linux/brcm-2.4/image/lzma-loader/src/Makefile
+++ b/target/linux/brcm-2.4/image/lzma-loader/src/Makefile
@@ -18,7 +18,7 @@
#
TEXT_START := 0x80001000
-BZ_TEXT_START := 0x80300000
+BZ_TEXT_START := 0x80400000
OBJCOPY := $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S