summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm-2.4/Makefile
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
committerTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
commit03beb39e5f76f6361adc99244afb4d274310d158 (patch)
treead51f5b31163969f63c468720c0ac606bf0fe17e /target/linux/brcm-2.4/Makefile
parentfa859ea32a7d0775e426b80757b37c09e3e2282c (diff)
downloadmaster-31e0f0ae-03beb39e5f76f6361adc99244afb4d274310d158.tar.gz
master-31e0f0ae-03beb39e5f76f6361adc99244afb4d274310d158.tar.bz2
master-31e0f0ae-03beb39e5f76f6361adc99244afb4d274310d158.zip
split out profile definitions from Makefiles
structure is as follows: target/linux/<arch>/profiles/<profilename>.mk These files are included by a blob match in the target Makefile The files should be labeled based on their profile Name in the definition SVN-Revision: 6468
Diffstat (limited to 'target/linux/brcm-2.4/Makefile')
-rw-r--r--target/linux/brcm-2.4/Makefile103
1 files changed, 2 insertions, 101 deletions
diff --git a/target/linux/brcm-2.4/Makefile b/target/linux/brcm-2.4/Makefile
index 28ee7b9205..3158d497af 100644
--- a/target/linux/brcm-2.4/Makefile
+++ b/target/linux/brcm-2.4/Makefile
@@ -21,106 +21,7 @@ KERNEL:=2.4
include $(INCLUDE_DIR)/kernel-build.mk
DEFAULT_PACKAGES += kmod-switch kmod-diag nvram
-define Profile/Broadcom
- NAME:=Generic, Broadcom WiFi (default)
- PACKAGES:=kmod-brcm-wl wlc nas kmod-wlcompat
-endef
-
-define Profile/Broadcom/Description
- Default package set compatible with most BCM947xx hardware
-endef
-$(eval $(call Profile,Broadcom))
-
-define Profile/BroadcomMimo
- NAME:=Generic, Broadcom WiFi (MIMO)
- PACKAGES:=kmod-brcm-wl-mimo wlc nas kmod-wlcompat
-endef
-
-define Profile/BroadcomMimo/Description
- Default package set compatible with 802.11n (draft) hardware
-endef
-$(eval $(call Profile,BroadcomMimo))
-
-define Profile/Atheros
- NAME:=Generic, Atheros WiFi
- PACKAGES:=kmod-madwifi
-endef
-
-define Profile/Atheros/Description
- Package set compatible with hardware using Atheros WiFi cards
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/None
- NAME:=Generic, No WiFi
- PACKAGES:=
-endef
-
-define Profile/None/Description
- Package set without WiFi support
-endef
-$(eval $(call Profile,None))
-
-
-define Profile/WRT54G3G
- NAME:=Linksys WRT54G3G
- PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt wlc nas kmod-wlcompat
-endef
-
-define Profile/WRT54G3G/Description
- Package set optimized for the WRT54G3G with UMTS support
-endef
-$(eval $(call Profile,WRT54G3G))
-
-define Profile/WL500G
- NAME:=ASUS WL-500g
- PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-lp wlc nas kmod-wlcompat
-endef
-
-define Profile/WL500G/Description
- Package set optimized for the WL-500g with USB and parallel port support
-endef
-$(eval $(call Profile,WL500G))
-
-define Profile/WL500GD
- NAME:=ASUS WL-500g Deluxe
- PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-uhci kmod-usb2 wlc nas kmod-wlcompat
-endef
-
-define Profile/WL500GD/Description
- Package set optimized for the WL-500g Deluxe with USB support
-endef
-$(eval $(call Profile,WL500GD))
-
-define Profile/WL500GP
- NAME:=ASUS WL-500g Premium
- PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 wlc nas kmod-wlcompat
-endef
-
-define Profile/WL500GP/Description
- Package set optimized for the WL-500g Premium with USB support
-endef
-$(eval $(call Profile,WL500GP))
-
-define Profile/WLHDD
- NAME:=WL-HDD
- PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx wlc nas kmod-wlcompat
-endef
-
-define Profile/WLHDD/Description
- Package set optimized for the WL-HDD with USB and IDE support
-endef
-$(eval $(call Profile,WLHDD))
-
-define Profile/WL700GE
- NAME:=WL-700gE
- PACKAGES:=-ppp -ppp-mod-pppoe -kmod-ipt-nathelper -iptables -dnsmasq -bridge kmod-ide-core kmod-ide-aec62xx kmod-fs-ext3 fdisk e2fsprogs
-endef
-
-define Profile/WL700GE/Description
- Minimal package set optimized for booting the WL-700gE from flash with a writable filesystem
- and the utilities to create a new filesystem on the HDD
-endef
-$(eval $(call Profile,WL700GE))
+# include the profiles
+-include profiles/*.mk
$(eval $(call BuildKernel))