summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2016-08-11 12:17:06 +0200
committerRafał Miłecki <rafal@milecki.pl>2016-08-11 12:17:06 +0200
commitfa350d5aba2e65826ab83e01ab28210836c0067f (patch)
tree0c157b973df9e07fcf904efe2bbde5b954f6f1c8 /target/linux/bcm53xx
parentb835d7e81173eb5823e7367bf8faba08619b9e09 (diff)
downloadmaster-31e0f0ae-fa350d5aba2e65826ab83e01ab28210836c0067f.tar.gz
master-31e0f0ae-fa350d5aba2e65826ab83e01ab28210836c0067f.tar.bz2
master-31e0f0ae-fa350d5aba2e65826ab83e01ab28210836c0067f.zip
bcm53xx: add profiles for Buffalo devices
This generates proper images when using CONFIG_TARGET_MULTI_PROFILE and CONFIG_TARGET_PER_DEVICE_ROOTFS. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile26
1 files changed, 24 insertions, 2 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 3fe5bc091b..09c8c9387d 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -118,6 +118,30 @@ define Device/asus-rt-n18u
endef
TARGET_DEVICES += asus-rt-n18u
+define Device/buffalo-wxr-1900dhp
+ DEVICE_TITLE := Buffalo WXR-1900DHP
+ DEVICE_PACKAGES := $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += buffalo-wxr-1900dhp
+
+define Device/buffalo-wzr-600dhp2
+ DEVICE_TITLE := Buffalo WZR-600DHP2
+ DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
+endef
+TARGET_DEVICES += buffalo-wzr-600dhp2
+
+define Device/buffalo-wzr-900dhp
+ DEVICE_TITLE := Buffalo WZR-900DHP
+ DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += buffalo-wzr-900dhp
+
+define Device/buffalo-wzr-1750dhp
+ DEVICE_TITLE := Buffalo WZR-1750DHP
+ DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += buffalo-wzr-1750dhp
+
define Device/dlink
IMAGES := bin
IMAGE/bin := append-ubi | seama-nand
@@ -196,8 +220,6 @@ define Device/smartrg-sr400ac
endef
TARGET_DEVICES += \
- buffalo-wzr-1750dhp buffalo-wzr-600dhp2 buffalo-wzr-900dhp \
- buffalo-wxr-1900dhp \
netgear-r6250 netgear-r6300-v2 netgear-r8000 \
smartrg-sr400ac