summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2016-08-14 16:00:10 +0200
committerRafał Miłecki <rafal@milecki.pl>2016-08-19 11:38:44 +0200
commitd22ae5e888f4905ba843670181587bf201e1b14d (patch)
treeac96e321b471393c3cf9932a7dc17d2ee677aafe /target/linux/bcm53xx
parentf3923dab7b79e436292ce51c2cdc358dac2c81f3 (diff)
downloadmaster-31e0f0ae-d22ae5e888f4905ba843670181587bf201e1b14d.tar.gz
master-31e0f0ae-d22ae5e888f4905ba843670181587bf201e1b14d.tar.bz2
master-31e0f0ae-d22ae5e888f4905ba843670181587bf201e1b14d.zip
bcm53xx: package drivers for Northstar USB PHYs
We don't use them yet as we still init PHY in controller driver but they will be needed soon. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/modules.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/modules.mk b/target/linux/bcm53xx/modules.mk
new file mode 100644
index 0000000000..ad799b8af0
--- /dev/null
+++ b/target/linux/bcm53xx/modules.mk
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2016 Rafał Miłecki <rafal@milecki.pl>
+#
+# This is free software, licensed under the GNU General Public License v2.
+#
+
+define KernelPackage/phy-bcm-ns-usb2
+ TITLE:=Broadcom Northstar USB 2.0 PHY Driver
+ KCONFIG:=CONFIG_PHY_BCM_NS_USB2
+ DEPENDS:=@TARGET_bcm53xx
+ SUBMENU:=$(USB_MENU)
+ FILES:=$(LINUX_DIR)/drivers/phy/phy-bcm-ns-usb2.ko
+ AUTOLOAD:=$(call AutoLoad,45,phy-bcm-ns-usb2,1)
+endef
+
+define KernelPackage/phy-bcm-ns-usb2/description
+ Support for Broadcom USB 2.0 PHY connected to the USB controller on Northstar
+ family.
+endef
+
+$(eval $(call KernelPackage,phy-bcm-ns-usb2))
+
+define KernelPackage/phy-bcm-ns-usb3
+ TITLE:=Broadcom Northstar USB 3.0 PHY Driver
+ KCONFIG:=CONFIG_PHY_BCM_NS_USB3
+ DEPENDS:=@TARGET_bcm53xx
+ SUBMENU:=$(USB_MENU)
+ FILES:=$(LINUX_DIR)/drivers/phy/phy-bcm-ns-usb3.ko
+ AUTOLOAD:=$(call AutoLoad,45,phy-bcm-ns-usb3,1)
+endef
+
+define KernelPackage/phy-bcm-ns-usb3/description
+ Support for Broadcom USB 3.0 PHY connected to the USB controller on Northstar
+ family.
+endef
+
+$(eval $(call KernelPackage,phy-bcm-ns-usb3))