summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2016-08-11 11:59:28 +0200
committerRafał Miłecki <rafal@milecki.pl>2016-08-11 11:59:28 +0200
commitb835d7e81173eb5823e7367bf8faba08619b9e09 (patch)
treeb4d33a92fcb7ac1360343d83a769dbe7da323de8 /target/linux/bcm53xx
parent0b9de8daa70e2fc1c5e680e12559af77fe90d325 (diff)
downloadmaster-31e0f0ae-b835d7e81173eb5823e7367bf8faba08619b9e09.tar.gz
master-31e0f0ae-b835d7e81173eb5823e7367bf8faba08619b9e09.tar.bz2
master-31e0f0ae-b835d7e81173eb5823e7367bf8faba08619b9e09.zip
bcm53xx: include USB modules in images for devices with USB ports
This allows using USB out of the box. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index aec5e8997d..3fe5bc091b 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -70,6 +70,9 @@ endef
DEVICE_VARS += PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION
+USB2_PACKAGES := kmod-usb-ohci kmod-usb2
+USB3_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3
+
define Device/Default
# .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
# extract the full dtb name based on the device info
@@ -93,22 +96,25 @@ endef
define Device/asus-rt-ac56u
DEVICE_TITLE := Asus RT-AC56U
- DEVICE_PACKAGES := kmod-b43
+ DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
endef
TARGET_DEVICES += asus-rt-ac56u
define Device/asus-rt-ac68u
DEVICE_TITLE := Asus RT-AC68U
+ DEVICE_PACKAGES := $(USB3_PACKAGES)
endef
TARGET_DEVICES += asus-rt-ac68u
define Device/asus-rt-ac87u
DEVICE_TITLE := Asus RT-AC87U
+ DEVICE_PACKAGES := $(USB3_PACKAGES)
endef
TARGET_DEVICES += asus-rt-ac87u
define Device/asus-rt-n18u
DEVICE_TITLE := Asus RT-N18U
+ DEVICE_PACKAGES := $(USB3_PACKAGES)
endef
TARGET_DEVICES += asus-rt-n18u
@@ -119,7 +125,7 @@ endef
define Device/dlink-dir-885l
DEVICE_TITLE := D-Link DIR-885L
- DEVICE_PACKAGES := kmod-brcmfmac
+ DEVICE_PACKAGES := kmod-brcmfmac $(USB3_PACKAGES)
$(Device/dlink)
SIGNATURE := wrgac42_dlink.2015_dir885l
endef
@@ -127,7 +133,7 @@ TARGET_DEVICES += dlink-dir-885l
define Device/linksys-ea6300-v1
DEVICE_TITLE := Linksys EA6300 V1
- DEVICE_PACKAGES := kmod-b43
+ DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
endef
TARGET_DEVICES += linksys-ea6300-v1
@@ -139,20 +145,21 @@ endef
define Device/netgear-r6250
DEVICE_TITLE := Netgear R6250
- DEVICE_PACKAGES := kmod-b43
+ DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
$(Device/netgear)
NETGEAR_BOARD_ID := U12H245T00_NETGEAR
endef
define Device/netgear-r6300-v2
DEVICE_TITLE := Netgear R6300 V2
- DEVICE_PACKAGES := kmod-b43
+ DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
$(Device/netgear)
NETGEAR_BOARD_ID := U12H240T00_NETGEAR
endef
define Device/netgear-r7000
DEVICE_TITLE := Netgear R7000
+ DEVICE_PACKAGES := $(USB3_PACKAGES)
$(Device/netgear)
NETGEAR_BOARD_ID := U12H270T00_NETGEAR
endef
@@ -160,7 +167,7 @@ TARGET_DEVICES += netgear-r7000
define Device/netgear-r7900
DEVICE_TITLE := Netgear R7900
- DEVICE_PACKAGES := kmod-brcmfmac
+ DEVICE_PACKAGES := kmod-brcmfmac $(USB3_PACKAGES)
$(Device/netgear)
NETGEAR_BOARD_ID := U12H315T30_NETGEAR
endef
@@ -168,14 +175,14 @@ TARGET_DEVICES += netgear-r7900
define Device/netgear-r8000
DEVICE_TITLE := Netgear R8000
- DEVICE_PACKAGES := kmod-brcmfmac
+ DEVICE_PACKAGES := kmod-brcmfmac $(USB3_PACKAGES)
$(Device/netgear)
NETGEAR_BOARD_ID := U12H315T00_NETGEAR
endef
define Device/netgear-r8500
DEVICE_TITLE := Netgear R8500
- DEVICE_PACKAGES := kmod-brcmfmac
+ DEVICE_PACKAGES := kmod-brcmfmac $(USB3_PACKAGES)
$(Device/netgear)
NETGEAR_BOARD_ID := U12H334T00_NETGEAR
endef
@@ -183,7 +190,7 @@ endef
define Device/smartrg-sr400ac
DEVICE_TITLE := SmartRG SR400ac
- DEVICE_PACKAGES := kmod-brcmfmac
+ DEVICE_PACKAGES := kmod-brcmfmac $(USB3_PACKAGES)
IMAGES := trx
IMAGE/trx := append-rootfs | trx-serial
endef