summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorBen Whitten <ben.whitten@lairdtech.com>2016-06-17 15:00:17 +0100
committerJohn Crispin <john@phrozen.org>2016-06-22 19:32:06 +0200
commitb7baaaf782f40bf6a1d017a1f41480b6229a12c9 (patch)
tree9b6969fd16d1ca63c61cdbfbe75a5bfeb1d25127 /target/linux/bcm53xx
parent7385f754b1a1562869ddf6a561f70623d626ed6b (diff)
downloadmaster-31e0f0ae-b7baaaf782f40bf6a1d017a1f41480b6229a12c9.tar.gz
master-31e0f0ae-b7baaaf782f40bf6a1d017a1f41480b6229a12c9.tar.bz2
master-31e0f0ae-b7baaaf782f40bf6a1d017a1f41480b6229a12c9.zip
kernel: Move append-dtb to common image-commands
This build step is used by various targets, move it to a common section. Signed-off-by: Ben Whitten <ben.whitten@gmail.com>
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 04e418d1e9..052900053e 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -8,8 +8,6 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/Prepare
- $(CP) $(DTS_DIR)/*.dtb $(KDIR)/
-
rm -f $(KDIR)/fs_mark
echo -ne '\xde\xad\xc0\xde' > $(KDIR)/fs_mark
$(call prepare_generic_squashfs,$(KDIR)/fs_mark)
@@ -21,10 +19,6 @@ define Image/Prepare
$(CP) ./ubinize.cfg $(KDIR)
endef
-define Build/append-dtb
- cat $(KDIR)/$(DT).dtb >> $@
-endef
-
define Build/lzma-d16
$(STAGING_DIR_HOST)/bin/lzma e $@ -d16 $(1) $@.new
@mv $@.new $@
@@ -78,14 +72,14 @@ define Build/seama-nand
-i $@.entity
endef
-DEVICE_VARS += DT PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION
+DEVICE_VARS += DEVICE_DTS PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION
define Device/Default
# .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
# extract the full dtb name based on the device info
- DT := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
+ DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
KERNEL := kernel-bin | append-dtb | lzma-d16
- KERNEL_DEPENDS = $$(wildcard $(KDIR)/$$(DT).dts)
+ KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
FILESYSTEMS := squashfs
KERNEL_NAME := zImage
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)