summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-30 14:19:11 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-31 12:25:25 +0200
commit63b525dd6b209af5554a2d053efd4b3ce6f60c9c (patch)
treeb4bf688fa7ce3b9cbbad996dd0d60730eacbede9 /target/linux/bcm53xx
parent9201e88f518dbe5246aa2f77342175805ef10cdd (diff)
downloadmaster-31e0f0ae-63b525dd6b209af5554a2d053efd4b3ce6f60c9c.tar.gz
master-31e0f0ae-63b525dd6b209af5554a2d053efd4b3ce6f60c9c.tar.bz2
master-31e0f0ae-63b525dd6b209af5554a2d053efd4b3ce6f60c9c.zip
image: add a helper variable for getting kernel/rootfs from within image Build/* templates
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 89639f4344..10474eb3b9 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -26,7 +26,7 @@ define Build/trx-serial
$(STAGING_DIR_HOST)/bin/trx \
-o $@.new \
-m 33554432 \
- -f $(word 1,$^) -a 1024 \
+ -f $(IMAGE_KERNEL) -a 1024 \
-f $@ -a 0x10000 -A $(KDIR)/fs_mark
mv $@.new $@
endef
@@ -39,7 +39,7 @@ define Build/trx-nand
$(STAGING_DIR_HOST)/bin/trx \
-o $@.new \
-m 33554432 \
- -f $(word 1,$^) -a 0x20000 -b 0x400000 \
+ -f $(IMAGE_KERNEL) -a 0x20000 -b 0x400000 \
-f $@ \
-A $(KDIR)/ubi_mark -a 0x20000
mv $@.new $@
@@ -57,7 +57,7 @@ define Build/seama-nand
entity $@.entity \
-m "dev=/dev/mtdblock/7" \
-m "type=firmware" \
- -f $(word 1,$^) \
+ -f $(IMAGE_KERNEL) \
-b 0x400000 \
-f $@ \
-f $(KDIR)/ubi_mark