summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2016-08-11 08:59:54 +0200
committerRafał Miłecki <rafal@milecki.pl>2016-08-11 11:31:46 +0200
commit0b9de8daa70e2fc1c5e680e12559af77fe90d325 (patch)
treed7d75e8d4878aed908f8b9bd479c9d75c93fb54c /target/linux/bcm53xx
parent4d39726b21c240c46206ae998d219b623ff31946 (diff)
downloadmaster-31e0f0ae-0b9de8daa70e2fc1c5e680e12559af77fe90d325.tar.gz
master-31e0f0ae-0b9de8daa70e2fc1c5e680e12559af77fe90d325.tar.bz2
master-31e0f0ae-0b9de8daa70e2fc1c5e680e12559af77fe90d325.zip
bcm53xx: add profiles for all other (SoftMAC) devices
Thanks to this images for SoftMAC devices don't get brcmfmac anymore and b43 is added for devices with (quite poor) support only. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile65
1 files changed, 34 insertions, 31 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 6b2b62a991..aec5e8997d 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -91,31 +91,32 @@ define Device/asus
IMAGE/trx := append-ubi | trx-nand | asus-trx
endef
-define AsusDevice
- define Device/asus-$(1)
- $$(Device/asus)
- PRODUCTID := $(2)
- endef
- TARGET_DEVICES += asus-$(1)
+define Device/asus-rt-ac56u
+ DEVICE_TITLE := Asus RT-AC56U
+ DEVICE_PACKAGES := kmod-b43
endef
+TARGET_DEVICES += asus-rt-ac56u
-define LinksysDevice
- TARGET_DEVICES += linksys-$(1)
+define Device/asus-rt-ac68u
+ DEVICE_TITLE := Asus RT-AC68U
endef
+TARGET_DEVICES += asus-rt-ac68u
+
+define Device/asus-rt-ac87u
+ DEVICE_TITLE := Asus RT-AC87U
+endef
+TARGET_DEVICES += asus-rt-ac87u
+
+define Device/asus-rt-n18u
+ DEVICE_TITLE := Asus RT-N18U
+endef
+TARGET_DEVICES += asus-rt-n18u
define Device/dlink
IMAGES := bin
IMAGE/bin := append-ubi | seama-nand
endef
-define DLinkDevice
- define Device/dlink-$(1)
- $$(Device/dlink)
- SIGNATURE := $(2)
- endef
- TARGET_DEVICES += dlink-$(1)
-endef
-
define Device/dlink-dir-885l
DEVICE_TITLE := D-Link DIR-885L
DEVICE_PACKAGES := kmod-brcmfmac
@@ -124,30 +125,39 @@ define Device/dlink-dir-885l
endef
TARGET_DEVICES += dlink-dir-885l
+define Device/linksys-ea6300-v1
+ DEVICE_TITLE := Linksys EA6300 V1
+ DEVICE_PACKAGES := kmod-b43
+endef
+TARGET_DEVICES += linksys-ea6300-v1
+
define Device/netgear
IMAGES := chk
IMAGE/chk := append-ubi | trx-nand | netgear-chk
NETGEAR_REGION := 1
endef
-define NetgearDevice
- define Device/netgear-$(1)
- $$(Device/netgear)
- NETGEAR_BOARD_ID := $(2)
- endef
- TARGET_DEVICES += netgear-$(1)
-endef
-
define Device/netgear-r6250
+ DEVICE_TITLE := Netgear R6250
+ DEVICE_PACKAGES := kmod-b43
$(Device/netgear)
NETGEAR_BOARD_ID := U12H245T00_NETGEAR
endef
define Device/netgear-r6300-v2
+ DEVICE_TITLE := Netgear R6300 V2
+ DEVICE_PACKAGES := kmod-b43
$(Device/netgear)
NETGEAR_BOARD_ID := U12H240T00_NETGEAR
endef
+define Device/netgear-r7000
+ DEVICE_TITLE := Netgear R7000
+ $(Device/netgear)
+ NETGEAR_BOARD_ID := U12H270T00_NETGEAR
+endef
+TARGET_DEVICES += netgear-r7000
+
define Device/netgear-r7900
DEVICE_TITLE := Netgear R7900
DEVICE_PACKAGES := kmod-brcmfmac
@@ -184,11 +194,4 @@ TARGET_DEVICES += \
netgear-r6250 netgear-r6300-v2 netgear-r8000 \
smartrg-sr400ac
-$(eval $(call AsusDevice,rt-ac56u,RT-AC56U))
-$(eval $(call AsusDevice,rt-ac68u,RT-AC68U))
-$(eval $(call AsusDevice,rt-ac87u,RT-AC87U))
-$(eval $(call AsusDevice,rt-n18u,RT-N18U))
-$(eval $(call LinksysDevice,ea6300-v1))
-$(eval $(call NetgearDevice,r7000,U12H270T00_NETGEAR))
-
$(eval $(call BuildImage))