summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2014-09-22 09:16:20 +0000
committerRafał Miłecki <zajec5@gmail.com>2014-09-22 09:16:20 +0000
commit23a07c6d18379ffd9da972ab5962e99242d05012 (patch)
tree871bae27d2268ab47943685c071a9e42ef815727 /target/linux/bcm53xx
parentfd515112dba58374552a072c86e83273ec4d3c64 (diff)
downloadmaster-31e0f0ae-23a07c6d18379ffd9da972ab5962e99242d05012.tar.gz
master-31e0f0ae-23a07c6d18379ffd9da972ab5962e99242d05012.tar.bz2
master-31e0f0ae-23a07c6d18379ffd9da972ab5962e99242d05012.zip
bcm53xx: image: make filesystem a suffix for TRX files
This makes TRX files more /compatible/ with firmware files (e.g. CHK). This will allow us to put some TRX files in BIN_DIR if we need to. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 42646
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index fd303c4e4b..d5093e03f2 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -16,14 +16,14 @@ endef
# $(1): dts filename (also used for the firmware file).
define Image/Build/initramfs/DTB
$(call Image/Build/DTB,zImage-initramfs,$(1))
- $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-initramfs-$(1).trx \
+ $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-$(1)-initramfs.trx \
-f $(KDIR)/zImage-initramfs-$(1).lzma
endef
# $(1): dts filename (also used for the firmware file).
define Image/Build/squashfs/DTB
$(call Image/Build/DTB,zImage,$(1))
- $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-squashfs-$(1).trx \
+ $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/$(IMG_PREFIX)-$(1)-squashfs.trx \
-f $(KDIR)/zImage-$(1).lzma \
-a 1024 -f $(KDIR)/root.squashfs -a 0x10000 -A $(KDIR)/fs_mark
endef
@@ -43,7 +43,7 @@ endef
# $(4): region.
define Image/Build/Chk
$(call Image/Build/$(1)/DTB,$(2))
- $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/openwrt-$(2)-$(1).chk -k $(KDIR)/$(IMG_PREFIX)-$(1)-$(2).trx -b $(3) -r $(4)
+ $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/openwrt-$(2)-$(1).chk -k $(KDIR)/$(IMG_PREFIX)-$(2)-$(1).trx -b $(3) -r $(4)
endef
# $(1): filesystem type (e.g. squashfs, initramfs).