summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/patches-4.1
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-12-02 15:19:29 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-12-02 15:19:29 +0000
commitc03f264f6d8a00249ab86574884c615ea8fda5a4 (patch)
tree596504cd88ceda026c67a711ebf66c526e35fa88 /target/linux/bcm53xx/patches-4.1
parent1d1c9d56dd77a9fe55a811f2ffc2bc2e804fe010 (diff)
downloadmaster-31e0f0ae-c03f264f6d8a00249ab86574884c615ea8fda5a4.tar.gz
master-31e0f0ae-c03f264f6d8a00249ab86574884c615ea8fda5a4.tar.bz2
master-31e0f0ae-c03f264f6d8a00249ab86574884c615ea8fda5a4.zip
bcm53xx: activate workarounds for erratas
This also deactivates some workaround for erratas only seen in older CPU cores and L2 cores not used in this SoC. This partly reverts commit r44947. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47686
Diffstat (limited to 'target/linux/bcm53xx/patches-4.1')
-rw-r--r--target/linux/bcm53xx/patches-4.1/020-ARM-BCM5310X-activate-erratas-needed-for-SoC.patch31
-rw-r--r--target/linux/bcm53xx/patches-4.1/131-ARM-BCM-Add-SMP-support-for-Broadcom-4708.patch11
2 files changed, 36 insertions, 6 deletions
diff --git a/target/linux/bcm53xx/patches-4.1/020-ARM-BCM5310X-activate-erratas-needed-for-SoC.patch b/target/linux/bcm53xx/patches-4.1/020-ARM-BCM5310X-activate-erratas-needed-for-SoC.patch
new file mode 100644
index 0000000000..d1868f3f87
--- /dev/null
+++ b/target/linux/bcm53xx/patches-4.1/020-ARM-BCM5310X-activate-erratas-needed-for-SoC.patch
@@ -0,0 +1,31 @@
+From f4ce7effe2253a325f8ba182903cbdf0d8698593 Mon Sep 17 00:00:00 2001
+From: Hauke Mehrtens <hauke@hauke-m.de>
+Date: Sat, 21 Nov 2015 15:29:47 +0100
+Subject: [PATCH] ARM: BCM5310X: activate erratas needed for SoC
+
+The BCM4708 I have, which is probably the first generation which got
+to the consumer market, is using a ARM Cortex-A9 rev r3p0 and a
+L2C-310 rev r3p2 L2 cache controller. There are 3 workarounds for known
+erratas in the Linux kernel which could be activated and will be in
+this patch. There are currently no workarounds which have to be
+activated for the L2C-310 rev r3p2 in Linux.
+
+Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/mach-bcm/Kconfig | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- a/arch/arm/mach-bcm/Kconfig
++++ b/arch/arm/mach-bcm/Kconfig
+@@ -38,6 +38,10 @@ config ARCH_BCM_CYGNUS
+ config ARCH_BCM_5301X
+ bool "Broadcom BCM470X / BCM5301X ARM SoC" if ARCH_MULTI_V7
+ select ARCH_BCM_IPROC
++ select ARM_ERRATA_754322
++ select ARM_ERRATA_775420
++ select ARM_ERRATA_764369 if SMP
++
+ help
+ Support for Broadcom BCM470X and BCM5301X SoCs with ARM CPU cores.
+
diff --git a/target/linux/bcm53xx/patches-4.1/131-ARM-BCM-Add-SMP-support-for-Broadcom-4708.patch b/target/linux/bcm53xx/patches-4.1/131-ARM-BCM-Add-SMP-support-for-Broadcom-4708.patch
index 4cd0473033..a23aa5df36 100644
--- a/target/linux/bcm53xx/patches-4.1/131-ARM-BCM-Add-SMP-support-for-Broadcom-4708.patch
+++ b/target/linux/bcm53xx/patches-4.1/131-ARM-BCM-Add-SMP-support-for-Broadcom-4708.patch
@@ -27,15 +27,14 @@ Signed-off-by: Jon Mason <jonmason@broadcom.com>
device_type = "cpu";
--- a/arch/arm/mach-bcm/Kconfig
+++ b/arch/arm/mach-bcm/Kconfig
-@@ -38,6 +38,8 @@ config ARCH_BCM_CYGNUS
- config ARCH_BCM_5301X
- bool "Broadcom BCM470X / BCM5301X ARM SoC" if ARCH_MULTI_V7
- select ARCH_BCM_IPROC
-+ select ARM_ERRATA_764369 if SMP
+@@ -41,6 +41,7 @@ config ARCH_BCM_5301X
+ select ARM_ERRATA_754322
+ select ARM_ERRATA_775420
+ select ARM_ERRATA_764369 if SMP
+ select HAVE_SMP
+
help
Support for Broadcom BCM470X and BCM5301X SoCs with ARM CPU cores.
-
--- a/arch/arm/mach-bcm/Makefile
+++ b/arch/arm/mach-bcm/Makefile
@@ -36,6 +36,9 @@ obj-$(CONFIG_ARCH_BCM2835) += board_bcm2