summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-09-26 22:57:33 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-09-26 22:57:33 +0000
commitc6401c6d617748f2f76cf548e525c88b9942ce98 (patch)
treee611e75e0cc04c73b77fce242b42ac6215708658 /target/linux/bcm53xx/image
parent877f2972d4d8f63644f18688cff7efd7ce280f2b (diff)
downloadmaster-31e0f0ae-c6401c6d617748f2f76cf548e525c88b9942ce98.tar.gz
master-31e0f0ae-c6401c6d617748f2f76cf548e525c88b9942ce98.tar.bz2
master-31e0f0ae-c6401c6d617748f2f76cf548e525c88b9942ce98.zip
bcm53xx: add early support for Linksys EA6300 V1
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 47052
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 7aa9fc2a3a..c9987dddc7 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -87,6 +87,18 @@ define AsusDevice
TARGET_DEVICES += asus-$(1)
endef
+define Device/linksys
+ IMAGES := trx
+ IMAGE/trx := trx-nand
+endef
+
+define LinksysDevice
+ define Device/linksys-$(1)
+ $$(Device/linksys)
+ endef
+ TARGET_DEVICES += linksys-$(1)
+endef
+
define Device/netgear
IMAGES := chk
IMAGE/chk := trx-nand | netgear-chk
@@ -131,6 +143,7 @@ $(eval $(call AsusDevice,rt-ac56u,RT-AC56U))
$(eval $(call AsusDevice,rt-ac68u,RT-AC68U))
$(eval $(call AsusDevice,rt-ac87u,RT-AC87U))
$(eval $(call AsusDevice,rt-n18u,RT-N18U))
+$(eval $(call LinksysDevice,ea6300-v1))
$(eval $(call NetgearDevice,r7000,U12H270T00_NETGEAR))
$(eval $(call BuildImage))