summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-04-21 08:19:53 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-04-21 08:19:53 +0000
commitac6879caaa0e18015b8d4b3a99bdab4e0d758508 (patch)
treeee3a3f96f0ee2e8160f5b78ee6dd2d5daa7b562c /target/linux/bcm53xx/image
parentc6cd1f1632ae2a4ed51e2cf52629037e4ef1d1d7 (diff)
downloadmaster-31e0f0ae-ac6879caaa0e18015b8d4b3a99bdab4e0d758508.tar.gz
master-31e0f0ae-ac6879caaa0e18015b8d4b3a99bdab4e0d758508.tar.bz2
master-31e0f0ae-ac6879caaa0e18015b8d4b3a99bdab4e0d758508.zip
bcm53xx: always use 4 MiB for TRX kernel partition to simplify upgrades
Signed-off-by: Dan Haab <dhaab@luxul.com> SVN-Revision: 45540
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 4720aaf309..b3f2cd8127 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -31,12 +31,14 @@ define Build/mkfs/squashfs
endef
define Build/trx-nand
+ # kernel: always use 4 MiB (-28 B or TRX header) to allow upgrades even
+ # if it grows up between releases
$(STAGING_DIR_HOST)/bin/trx \
-o $@ \
-m 33554432 \
- -f $(word 1,$^) \
- -a 0x20000 -f $(KDIR)/root-block-0x20000-min-0x800.ubi \
- -a 0x20000 -A $(KDIR)/fs_mark
+ -f $(word 1,$^) -a 0x20000 -b 0x400000 \
+ -f $(KDIR)/root-block-0x20000-min-0x800.ubi -a 0x20000 \
+ -A $(KDIR)/fs_mark
endef
define Build/netgear-chk