summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-05-27 16:20:06 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-05-27 16:20:06 +0000
commit9845d729a9fbc7a5d39ba65cca0081351e4faca7 (patch)
tree2409fae3aa8d5971d7fe75e53b06b6e87d09b4ba /target/linux/bcm53xx/image
parent69aefc771fd8a7d7450e856a5432fcc15cfc8fc9 (diff)
downloadmaster-31e0f0ae-9845d729a9fbc7a5d39ba65cca0081351e4faca7.tar.gz
master-31e0f0ae-9845d729a9fbc7a5d39ba65cca0081351e4faca7.tar.bz2
master-31e0f0ae-9845d729a9fbc7a5d39ba65cca0081351e4faca7.zip
bcm53xx: build images for Asus devices
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 45790
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile27
1 files changed, 25 insertions, 2 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 4b61e1330b..b22dfe59c5 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -54,13 +54,19 @@ define Build/trx-nand
-A $(KDIR)/ubi_mark -a 0x20000
endef
+define Build/asus-trx
+ $(STAGING_DIR_HOST)/bin/asustrx \
+ -p $(PRODUCTID) -i $@ -o $@.new
+ mv $@.new $@
+endef
+
define Build/netgear-chk
$(STAGING_DIR_HOST)/bin/mkchkimg \
-o $@.new -k $@ -b $(BOARD_ID) -r $(REGION)
mv $@.new $@
endef
-DEVICE_VARS += DT BOARD_ID REGION
+DEVICE_VARS += DT PRODUCTID BOARD_ID REGION
define Device/Default
# .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
@@ -74,6 +80,19 @@ define Device/Default
IMAGE/trx := trx-nand
endef
+define Device/asus
+ IMAGES := trx
+ IMAGE/trx := trx-nand | asus-trx
+endef
+
+define AsusDevice
+ define Device/asus-$(1)
+ $$(Device/asus)
+ PRODUCTID := $(2)
+ endef
+ TARGET_DEVICES += asus-$(1)
+endef
+
define Device/netgear
IMAGES := chk
IMAGE/chk := trx-nand | netgear-chk
@@ -101,10 +120,14 @@ define Device/smartrg-sr400ac
endef
TARGET_DEVICES += \
- asus-rt-ac56u asus-rt-ac68u asus-rt-ac87u asus-rt-n18u \
buffalo-wzr-1750dhp buffalo-wzr-600dhp2 buffalo-wzr-900dhp \
buffalo-wxr-1900dhp \
netgear-r6250 netgear-r6300-v2 netgear-r8000 \
smartrg-sr400ac
+$(eval $(call AsusDevice,rt-ac56u,RT-AC56U))
+$(eval $(call AsusDevice,rt-ac68u,RT-AC68U))
+$(eval $(call AsusDevice,rt-ac87u,RT-AC87U))
+$(eval $(call AsusDevice,rt-n18u,RT-N18U))
+
$(eval $(call BuildImage))