summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2014-10-09 16:36:05 +0000
committerRafał Miłecki <zajec5@gmail.com>2014-10-09 16:36:05 +0000
commit9473673ae33c0d856124ffcb10fefefdc61c82e7 (patch)
tree2353bb066b2f759f9faf2c026124371e67873bdb /target/linux/bcm53xx/image
parentfbe1b7ecdf0d8ef1275276eab9b74c244c9a0f14 (diff)
downloadmaster-31e0f0ae-9473673ae33c0d856124ffcb10fefefdc61c82e7.tar.gz
master-31e0f0ae-9473673ae33c0d856124ffcb10fefefdc61c82e7.tar.bz2
master-31e0f0ae-9473673ae33c0d856124ffcb10fefefdc61c82e7.zip
bcm53xx: add support for Buffalo WZR-1750DHP
Let's generate a simple TRX file as we can't get encrypted one. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 42863
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 41104bffe6..4f22598861 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -39,6 +39,13 @@ endef
# $(1): filesystem type (e.g. squashfs, initramfs).
# $(2): dts filename (also used for the firmware file).
+define Image/Build/Trx
+ $(call Image/Build/$(1)/DTB,$(2))
+ cp $(KDIR)/$(IMG_PREFIX)-$(2)-$(1).trx $(BIN_DIR)/
+endef
+
+# $(1): filesystem type (e.g. squashfs, initramfs).
+# $(2): dts filename (also used for the firmware file).
# $(3): board_id (device specific magic).
# $(4): region.
define Image/Build/Chk
@@ -48,6 +55,8 @@ endef
# $(1): filesystem type (e.g. squashfs, initramfs).
define Image/Build
+ $(call Image/Build/Trx,$(1),bcm4708-buffalo-wzr-1750dhp)
+
$(call Image/Build/Chk,$(1),bcm4708-netgear-r6250,U12H245T00_NETGEAR,1)
$(call Image/Build/Chk,$(1),bcm4708-netgear-r6300-v2,U12H240T00_NETGEAR,1)
endef