summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2014-10-09 16:36:51 +0000
committerRafał Miłecki <zajec5@gmail.com>2014-10-09 16:36:51 +0000
commit78be7225c3d6741d8abfa9d9a7ac1f8e431a2cc5 (patch)
tree7cf0b67062373cc6aff89f50f9072ba68fb4b8cd /target/linux/bcm53xx/image
parent9473673ae33c0d856124ffcb10fefefdc61c82e7 (diff)
downloadmaster-31e0f0ae-78be7225c3d6741d8abfa9d9a7ac1f8e431a2cc5.tar.gz
master-31e0f0ae-78be7225c3d6741d8abfa9d9a7ac1f8e431a2cc5.tar.bz2
master-31e0f0ae-78be7225c3d6741d8abfa9d9a7ac1f8e431a2cc5.zip
bcm53xx: prepare to support Asus RT-N18U
DT file doesn't include any GPIOs yet, but let's add it as we got some interest in this device on IRC. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 42864
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 4f22598861..968388380a 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -39,6 +39,15 @@ endef
# $(1): filesystem type (e.g. squashfs, initramfs).
# $(2): dts filename (also used for the firmware file).
+# $(3): device specific magic.
+define Image/Build/AsusTrx
+ $(call Image/Build/$(1)/DTB,$(2))
+ # TODO: Put magic in TRX file
+ cp $(KDIR)/$(IMG_PREFIX)-$(2)-$(1).trx $(BIN_DIR)/
+endef
+
+# $(1): filesystem type (e.g. squashfs, initramfs).
+# $(2): dts filename (also used for the firmware file).
define Image/Build/Trx
$(call Image/Build/$(1)/DTB,$(2))
cp $(KDIR)/$(IMG_PREFIX)-$(2)-$(1).trx $(BIN_DIR)/
@@ -55,6 +64,8 @@ endef
# $(1): filesystem type (e.g. squashfs, initramfs).
define Image/Build
+ $(call Image/Build/AsusTrx,$(1),bcm47081-asus-rt-n18u,RT-N18U)
+
$(call Image/Build/Trx,$(1),bcm4708-buffalo-wzr-1750dhp)
$(call Image/Build/Chk,$(1),bcm4708-netgear-r6250,U12H245T00_NETGEAR,1)