summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-04-21 08:42:41 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-04-21 08:42:41 +0000
commit5b9d70c888a53082f70d36909ca82f9f2b215b34 (patch)
tree9017a14d0d097f5b043d22d4a41b1021a7006349 /target/linux/bcm53xx/image
parenta86e7330dcd74844f9cd0246e44800779f9ca3c7 (diff)
downloadmaster-31e0f0ae-5b9d70c888a53082f70d36909ca82f9f2b215b34.tar.gz
master-31e0f0ae-5b9d70c888a53082f70d36909ca82f9f2b215b34.tar.bz2
master-31e0f0ae-5b9d70c888a53082f70d36909ca82f9f2b215b34.zip
bcm53xx: image: prepare for generating serial flash images
There are some rare devices without NAND, like Netgear EX6200 or TP-LINK Archer C8. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 45545
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index fb909c4629..b299f38949 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -34,6 +34,13 @@ define Build/mkfs/squashfs
( cd $(KDIR); $(STAGING_DIR_HOST)/bin/ubinize -p 128KiB -m 2048 -o $(KDIR)/root-block-0x20000-min-0x800.ubi ubinize.cfg )
endef
+define Build/trx-serial
+ $(STAGING_DIR_HOST)/bin/trx \
+ -o $@ \
+ -f $(word 1,$^) -a 1024 \
+ -f $(KDIR)/root.squashfs -a 0x10000 -A $(KDIR)/fs_mark
+endef
+
define Build/trx-nand
# kernel: always use 4 MiB (-28 B or TRX header) to allow upgrades even
# if it grows up between releases