summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-06 18:39:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-06 18:39:06 +0000
commit2499a57d92409e767386d0d36684952c20735656 (patch)
tree7aa0faeea81f36c472f0473955718da5bc6a241d /target/linux/bcm53xx/image
parent4ab26a52ef687a42a318d52440e27d0f5a8d6769 (diff)
downloadmaster-31e0f0ae-2499a57d92409e767386d0d36684952c20735656.tar.gz
master-31e0f0ae-2499a57d92409e767386d0d36684952c20735656.tar.bz2
master-31e0f0ae-2499a57d92409e767386d0d36684952c20735656.zip
targets: add kernel image dependencies on device tree files
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48146
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index c9987dddc7..d9d4a80fa1 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -67,6 +67,7 @@ define Device/Default
# extract the full dtb name based on the device info
DT := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
KERNEL := kernel-bin | append-dtb | lzma-d16
+ KERNEL_DEPENDS = $$(wildcard $(KDIR)/$$(DT).dts)
FILESYSTEMS := squashfs
KERNEL_NAME := zImage
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)