summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2013-07-12 13:46:27 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2013-07-12 13:46:27 +0000
commit9e9261a7182c82947f1bbd7f63aa6a93a783e02e (patch)
tree77b0578b21c88e818fb6fb4507ea7c4325654582 /target/linux/bcm53xx/Makefile
parent92961e09178746996cba8fea04482d69a7e69201 (diff)
downloadmaster-31e0f0ae-9e9261a7182c82947f1bbd7f63aa6a93a783e02e.tar.gz
master-31e0f0ae-9e9261a7182c82947f1bbd7f63aa6a93a783e02e.tar.bz2
master-31e0f0ae-9e9261a7182c82947f1bbd7f63aa6a93a783e02e.zip
bcm53xx: add initial support for ARM based BCM47XX and BCM53XX SoCs
This was only tested on a Netgear R6250, but it could also work on other devices when the correct images are generated. It is only possible to boot into a ram disk, no Ethernet, Wifi, flash, USB is supported. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 37268
Diffstat (limited to 'target/linux/bcm53xx/Makefile')
-rw-r--r--target/linux/bcm53xx/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/Makefile b/target/linux/bcm53xx/Makefile
new file mode 100644
index 0000000000..ea3a3326bc
--- /dev/null
+++ b/target/linux/bcm53xx/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=bcm53xx
+BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
+FEATURES:=squashfs usb pci pcie gpio
+MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+
+LINUX_VERSION:=3.10
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
+endef
+
+CFLAGS:=-Os -pipe -mtune=cortex-a9 -march=armv7-a -mfpu=vfp -mfloat-abi=softfp
+
+KERNELNAME:="zImage dtbs"
+
+DEFAULT_PACKAGES +=
+
+$(eval $(call BuildTarget))