summaryrefslogtreecommitdiffstats
path: root/target/linux/au1000
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-29 11:03:55 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-29 11:03:55 +0000
commitf19757215be1f4a661c4b29839dd74b25f21a78c (patch)
treecfaeac91f02695eee47bd1abd6b0c48a63faa95a /target/linux/au1000
parent337c6f2d515ba7e57ae2d471d97ac6be98e92fd7 (diff)
downloadmaster-31e0f0ae-f19757215be1f4a661c4b29839dd74b25f21a78c.tar.gz
master-31e0f0ae-f19757215be1f4a661c4b29839dd74b25f21a78c.tar.bz2
master-31e0f0ae-f19757215be1f4a661c4b29839dd74b25f21a78c.zip
au1000: fix kmod-pcmcia-au1000
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 45817
Diffstat (limited to 'target/linux/au1000')
-rw-r--r--target/linux/au1000/modules.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/au1000/modules.mk b/target/linux/au1000/modules.mk
index e001db4280..079a2674d4 100644
--- a/target/linux/au1000/modules.mk
+++ b/target/linux/au1000/modules.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,9 +8,10 @@
define KernelPackage/pcmcia-au1000
SUBMENU:=$(PCMCIA_MENU)
TITLE:=RMI/AMD Au1000 PCMCIA support
- DEPENDS:=@TARGET_au1000 kmod-pcmcia-core
- FILES:=$(LINUX_DIR)/drivers/pcmcia/au1x00_ss.ko
- AUTOLOAD:=$(call AutoLoad,41,au1x00_ss)
+ DEPENDS:=@TARGET_au1000 +kmod-pcmcia-core
+ FILES:=$(LINUX_DIR)/drivers/pcmcia/db1xxx_ss.ko
+ KCONFIG:=CONFIG_PCMCIA_ALCHEMY_DEVBOARD
+ AUTOLOAD:=$(call AutoLoad,41,db1xxx_ss)
endef
$(eval $(call KernelPackage,pcmcia-au1000))