summaryrefslogtreecommitdiffstats
path: root/target/linux/au1000
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-11-07 12:46:12 +0000
committerJohn Crispin <john@openwrt.org>2013-11-07 12:46:12 +0000
commit8247d9926af6357c872755098f4b37067d274dcb (patch)
tree96ab1f565d855d60edf61dab95b92d1c1449775c /target/linux/au1000
parentf198adc0304af5cd6c232f80c40a8c47bf0a0da3 (diff)
downloadmaster-31e0f0ae-8247d9926af6357c872755098f4b37067d274dcb.tar.gz
master-31e0f0ae-8247d9926af6357c872755098f4b37067d274dcb.tar.bz2
master-31e0f0ae-8247d9926af6357c872755098f4b37067d274dcb.zip
au1000: create sysupgrade binary for each file system type
This patch should prevent overriding of sysupgrade binaries in the bin directory if we build images for more then one file system type. Discussion: https://lists.openwrt.org/pipermail/openwrt-devel/2013-October/022108.html Signed-off-by: Philipp Borgers <borgers@mi.fu-berlin.de> SVN-Revision: 38674
Diffstat (limited to 'target/linux/au1000')
-rw-r--r--target/linux/au1000/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/au1000/image/Makefile b/target/linux/au1000/image/Makefile
index 1dfdd9843c..12c84a10cf 100644
--- a/target/linux/au1000/image/Makefile
+++ b/target/linux/au1000/image/Makefile
@@ -62,7 +62,7 @@ define Image/Build
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).fs
$(CP) $(KDIR)/kernel.flash.srec $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-flash.srec
$(CP) $(KDIR)/kernel.ram.srec $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-ram.srec
- tar -C $(BIN_DIR) -cvzf $(BIN_DIR)/$(IMG_PREFIX)-sysupgrade.bin $(IMG_PREFIX)-vmlinux.bin $(IMG_PREFIX)-$(1).fs
+ tar -C $(BIN_DIR) -cvzf $(BIN_DIR)/$(IMG_PREFIX)-$(1)-sysupgrade.bin $(IMG_PREFIX)-vmlinux.bin $(IMG_PREFIX)-$(1).fs
ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
$(call Image/Build/Initramfs)
endif