summaryrefslogtreecommitdiffstats
path: root/target/linux/au1000
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-28 15:54:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-28 15:54:01 +0000
commit7d44f7630f172047c6e936bc3caef61005abc779 (patch)
tree15ac24f374a9734d4420ce0e20aaa463c1713f19 /target/linux/au1000
parent045966d4e958666aa9b26f693a02137312a11ac4 (diff)
downloadmaster-31e0f0ae-7d44f7630f172047c6e936bc3caef61005abc779.tar.gz
master-31e0f0ae-7d44f7630f172047c6e936bc3caef61005abc779.tar.bz2
master-31e0f0ae-7d44f7630f172047c6e936bc3caef61005abc779.zip
au1000: use srecimage.pl instead of objcopy, fixes imagebuilder
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 45809
Diffstat (limited to 'target/linux/au1000')
-rw-r--r--target/linux/au1000/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/au1000/image/Makefile b/target/linux/au1000/image/Makefile
index 63c0b03d68..3d5752930f 100644
--- a/target/linux/au1000/image/Makefile
+++ b/target/linux/au1000/image/Makefile
@@ -55,7 +55,7 @@ define Image/Build/Initramfs
endef
define Image/Build
- $(TARGET_CROSS)objcopy -O srec -I binary --adjust-vma $(FLASH_FS) $(KDIR)/root.$(1) $(KDIR)/root.$(1).srec
+ $(SCRIPT_DIR)/srecimage.pl $(KDIR)/root.$(1) $(KDIR)/root.$(1).srec $(FLASH_FS)
grep -v S7 $(KDIR)/root.$(1).srec > $(BIN_DIR)/$(IMG_PREFIX)-$(1).srec
grep -v S0 $(KDIR)/kernel.flash.srec >> $(BIN_DIR)/$(IMG_PREFIX)-$(1).srec
$(INSTALL_BIN) $(KDIR)/kernel.flash.bin $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.bin