summaryrefslogtreecommitdiffstats
path: root/target/linux/au1000
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-18 09:49:38 +0000
committerJohn Crispin <john@openwrt.org>2015-02-18 09:49:38 +0000
commit1a1d69da08216b3f503bccff3e371194d80e75dd (patch)
tree43317a648749c53605a201386c112fb495c17351 /target/linux/au1000
parentf9aa2ec7f6c12a6689dbaf8cbb66b6abe5863345 (diff)
downloadmaster-31e0f0ae-1a1d69da08216b3f503bccff3e371194d80e75dd.tar.gz
master-31e0f0ae-1a1d69da08216b3f503bccff3e371194d80e75dd.tar.bz2
master-31e0f0ae-1a1d69da08216b3f503bccff3e371194d80e75dd.zip
au1000: fix 3.18 and set it as default
Thanks to Bruno Randolf for testing and Manuel Lauss for providing a fix. Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44487
Diffstat (limited to 'target/linux/au1000')
-rw-r--r--target/linux/au1000/Makefile2
-rw-r--r--target/linux/au1000/patches/005-fix-cpu-clk.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/target/linux/au1000/Makefile b/target/linux/au1000/Makefile
index 0964561cd3..7438e9b6df 100644
--- a/target/linux/au1000/Makefile
+++ b/target/linux/au1000/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci
SUBTARGETS=au1500 au1550
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-KERNEL_PATCHVER:=3.14
+KERNEL_PATCHVER:=3.18
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini yamonenv
diff --git a/target/linux/au1000/patches/005-fix-cpu-clk.patch b/target/linux/au1000/patches/005-fix-cpu-clk.patch
new file mode 100644
index 0000000000..b925638817
--- /dev/null
+++ b/target/linux/au1000/patches/005-fix-cpu-clk.patch
@@ -0,0 +1,11 @@
+--- a/arch/mips/alchemy/common/clock.c
++++ b/arch/mips/alchemy/common/clock.c
+@@ -128,6 +128,8 @@
+ t = 396000000;
+ else {
+ t = alchemy_rdsys(AU1000_SYS_CPUPLL) & 0x7f;
++ if (alchemy_get_cputype() != ALCHEMY_CPU_AU1300)
++ t &= 0x3f;
+ t *= parent_rate;
+ }
+