summaryrefslogtreecommitdiffstats
path: root/target/linux/au1000/profiles
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit56231056ea784f1cec6450f649b1adaed1f56366 (patch)
tree7b130d72d854cde2bcd3af8b11bd0f7be3dbff6a /target/linux/au1000/profiles
parente1184aaa1a7a5e5eeef8e072bf0ea98c291be22a (diff)
downloadmaster-31e0f0ae-56231056ea784f1cec6450f649b1adaed1f56366.tar.gz
master-31e0f0ae-56231056ea784f1cec6450f649b1adaed1f56366.tar.bz2
master-31e0f0ae-56231056ea784f1cec6450f649b1adaed1f56366.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
SVN-Revision: 8653
Diffstat (limited to 'target/linux/au1000/profiles')
-rw-r--r--target/linux/au1000/profiles/Atheros.mk13
-rw-r--r--target/linux/au1000/profiles/Broadcom.mk13
-rw-r--r--target/linux/au1000/profiles/Intel.mk13
3 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/au1000/profiles/Atheros.mk b/target/linux/au1000/profiles/Atheros.mk
new file mode 100644
index 0000000000..ec6e175e80
--- /dev/null
+++ b/target/linux/au1000/profiles/Atheros.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/au1000/profiles/Broadcom.mk b/target/linux/au1000/profiles/Broadcom.mk
new file mode 100644
index 0000000000..d7fb9cb809
--- /dev/null
+++ b/target/linux/au1000/profiles/Broadcom.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom
+ NAME:=Broadcom BCM43xx WiFi
+ PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
diff --git a/target/linux/au1000/profiles/Intel.mk b/target/linux/au1000/profiles/Intel.mk
new file mode 100644
index 0000000000..be112eea91
--- /dev/null
+++ b/target/linux/au1000/profiles/Intel.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Intel
+ NAME:=Intel IPW2200 WiFi
+ PACKAGES:=kmod-net-ipw2200
+endef
+$(eval $(call Profile,Intel))
+