summaryrefslogtreecommitdiffstats
path: root/target/linux/au1000/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-09 18:53:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-09 18:53:06 +0000
commit93575b53a7d72b7208176a07d34b06a6e2598ac7 (patch)
treeace2f795f6550ab9b61ba0ebcadc0ce97af8b60a /target/linux/au1000/image
parentb0e20c3895e12bde51af29171cc3372f5f2692b7 (diff)
downloadmaster-31e0f0ae-93575b53a7d72b7208176a07d34b06a6e2598ac7.tar.gz
master-31e0f0ae-93575b53a7d72b7208176a07d34b06a6e2598ac7.tar.bz2
master-31e0f0ae-93575b53a7d72b7208176a07d34b06a6e2598ac7.zip
Use $(CP) instead of $(INSTALL_BIN) for binaries.
Signed-off-by: Andy Boyett <agb-openwrt@padded-cell.net> SVN-Revision: 9694
Diffstat (limited to 'target/linux/au1000/image')
-rw-r--r--target/linux/au1000/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/au1000/image/Makefile b/target/linux/au1000/image/Makefile
index 3013d62660..3cdd83e589 100644
--- a/target/linux/au1000/image/Makefile
+++ b/target/linux/au1000/image/Makefile
@@ -56,7 +56,7 @@ define Image/Build
$(TARGET_CROSS)objcopy -O srec -I binary --adjust-vma $(FLASH_FS) $(KDIR)/root.$(1) $(KDIR)/root.$(1).srec
grep -v S7 $(KDIR)/root.$(1).srec > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
grep -v S0 $(KDIR)/kernel.flash.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
- $(CP) $(KDIR)/kernel.flash.bin $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.bin
+ $(INSTALL_BIN) $(KDIR)/kernel.flash.bin $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.bin
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1).fs
$(CP) $(KDIR)/kernel.flash.srec $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-flash.srec
$(CP) $(KDIR)/kernel.ram.srec $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-ram.srec