summaryrefslogtreecommitdiffstats
path: root/target/linux/au1000-2.6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-12 01:23:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-12 01:23:37 +0000
commit6f30f6586f3b779f5967f16ec189206b3dc2adb8 (patch)
tree0d423e39c675eeca312811ee65490616892faf53 /target/linux/au1000-2.6
parent7790289f3e47f73861913e1ce72e26a853456dd5 (diff)
downloadmaster-31e0f0ae-6f30f6586f3b779f5967f16ec189206b3dc2adb8.tar.gz
master-31e0f0ae-6f30f6586f3b779f5967f16ec189206b3dc2adb8.tar.bz2
master-31e0f0ae-6f30f6586f3b779f5967f16ec189206b3dc2adb8.zip
add binary images for au1000 (for use with mtd)
SVN-Revision: 5767
Diffstat (limited to 'target/linux/au1000-2.6')
-rw-r--r--target/linux/au1000-2.6/image/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/target/linux/au1000-2.6/image/Makefile b/target/linux/au1000-2.6/image/Makefile
index 9c7bb06d3a..c9ab7caca9 100644
--- a/target/linux/au1000-2.6/image/Makefile
+++ b/target/linux/au1000-2.6/image/Makefile
@@ -25,7 +25,8 @@ define Build/Clean
endef
DROP_SECTIONS := .reginfo .mdebug .comment .note .pdr .options .MIPS.options
-OBJCOPY_KERNEL := $(TARGET_CROSS)objcopy -S -O srec $(addprefix --remove-section=,$(DROP_SECTIONS))
+OBJCOPY_SREC := $(TARGET_CROSS)objcopy -S -O srec $(addprefix --remove-section=,$(DROP_SECTIONS))
+OBJCOPY_BIN := $(TARGET_CROSS)objcopy -S -O binary $(addprefix --remove-section=,$(DROP_SECTIONS))
define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
@@ -34,7 +35,7 @@ define Image/Prepare
$(MAKE) -C ../../generic-2.6/image/lzma-loader \
$(LOADER_MAKEOPTS) \
clean compile
- $(OBJCOPY_KERNEL) $(KDIR)/loader.elf $(KDIR)/kernel.ram.srec
+ $(OBJCOPY_SREC) $(KDIR)/loader.elf $(KDIR)/kernel.ram.srec
# Build Flash image
$(MAKE) -C ../../generic-2.6/image/lzma-loader \
@@ -43,13 +44,16 @@ define Image/Prepare
LOADER_ENTRY=$(FLASH_KERNEL) \
LOADER_TYPE=_flash \
clean compile
- $(OBJCOPY_KERNEL) $(KDIR)/loader_flash.elf $(KDIR)/kernel.flash.srec
+ $(OBJCOPY_SREC) $(KDIR)/loader_flash.elf $(KDIR)/kernel.flash.srec
+ $(OBJCOPY_BIN) $(KDIR)/loader_flash.elf $(KDIR)/kernel.flash.bin
endef
define Image/Build
$(TARGET_CROSS)objcopy -O srec -I binary --adjust-vma $(FLASH_FS) $(KDIR)/root.$(1) $(KDIR)/root.$(1).srec
grep -v S7 $(KDIR)/root.$(1).srec > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
grep -v S0 $(KDIR)/kernel.flash.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+ $(CP) $(KDIR)/kernel.flash.bin $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.bin
+ $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).fs
endef
$(eval $(call BuildImage))