summaryrefslogtreecommitdiffstats
path: root/target/linux/atheros
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2008-05-08 19:37:06 +0000
committerTravis Kemen <thepeople@openwrt.org>2008-05-08 19:37:06 +0000
commit94c559b2333cbd147c4533d9920ee4fa0cc4ba5f (patch)
treebdf8415e015580c4f87d565b5e7cf2e91d313e2a /target/linux/atheros
parent1deffb0f407ba603e3884cb9115b89dd8ff1410e (diff)
downloadmaster-31e0f0ae-94c559b2333cbd147c4533d9920ee4fa0cc4ba5f.tar.gz
master-31e0f0ae-94c559b2333cbd147c4533d9920ee4fa0cc4ba5f.tar.bz2
master-31e0f0ae-94c559b2333cbd147c4533d9920ee4fa0cc4ba5f.zip
change image generation, no need for duplicate images
SVN-Revision: 11082
Diffstat (limited to 'target/linux/atheros')
-rw-r--r--target/linux/atheros/image/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
index 5a8d93deb5..3806d92e92 100644
--- a/target/linux/atheros/image/Makefile
+++ b/target/linux/atheros/image/Makefile
@@ -39,10 +39,8 @@ define Image/Build
echo -en "\t0x$(shell printf "%08X\n" $(shell expr 3866624 - $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c) ) )" >> $(BIN_DIR)/ls2-parts
echo -e "\t0x00000000\t0x00000000\t$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)" >> $(BIN_DIR)/ls2-parts
- $(STAGING_DIR_HOST)/bin/mkfwimage -i $(BIN_DIR)/ls2-parts -v XS2.ar2316.OpenWRT -o $(BIN_DIR)/openwrt-$(BOARD)-litestation2-$(1).bin
- $(STAGING_DIR_HOST)/bin/mkfwimage -i $(BIN_DIR)/ls5-parts -v XS5.ar2313.OpenWRT -o $(BIN_DIR)/openwrt-$(BOARD)-litestation5-$(1).bin
- cp $(BIN_DIR)/openwrt-$(BOARD)-litestation5-$(1).bin $(BIN_DIR)/openwrt-$(BOARD)-nanostation5-$(1).bin
- cp $(BIN_DIR)/openwrt-$(BOARD)-litestation2-$(1).bin $(BIN_DIR)/openwrt-$(BOARD)-nanostation2-$(1).bin
+ $(STAGING_DIR_HOST)/bin/mkfwimage -i $(BIN_DIR)/ls2-parts -v XS2.ar2316.OpenWRT -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt-$(1).bin
+ $(STAGING_DIR_HOST)/bin/mkfwimage -i $(BIN_DIR)/ls5-parts -v XS5.ar2313.OpenWRT -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt-$(1).bin
rm $(BIN_DIR)/ls2-parts $(BIN_DIR)/ls5-parts
endef