summaryrefslogtreecommitdiffstats
path: root/target/linux/atheros
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-09-12 06:53:27 +0000
committerJohn Crispin <john@openwrt.org>2014-09-12 06:53:27 +0000
commit4156c9734aa78a7cf41104068363b80345986b5c (patch)
tree6104833402c3cec8db577140071d816cfabfb0ad /target/linux/atheros
parentfb4196ec2af752f6660ee2e813844357c1150552 (diff)
downloadmaster-31e0f0ae-4156c9734aa78a7cf41104068363b80345986b5c.tar.gz
master-31e0f0ae-4156c9734aa78a7cf41104068363b80345986b5c.tar.bz2
master-31e0f0ae-4156c9734aa78a7cf41104068363b80345986b5c.zip
atheros: ar2315-pci: rename configuration symbol
Rename configuration symbol to be consistent with other MIPS machines. Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> SVN-Revision: 42505
Diffstat (limited to 'target/linux/atheros')
-rw-r--r--target/linux/atheros/config-3.142
-rw-r--r--target/linux/atheros/patches-3.14/105-ar2315_pci.patch11
2 files changed, 7 insertions, 6 deletions
diff --git a/target/linux/atheros/config-3.14 b/target/linux/atheros/config-3.14
index f27d1c22d0..a0bb6e9fb0 100644
--- a/target/linux/atheros/config-3.14
+++ b/target/linux/atheros/config-3.14
@@ -12,7 +12,6 @@ CONFIG_ARCH_REQUIRE_GPIOLIB=y
CONFIG_ARCH_SUSPEND_POSSIBLE=y
CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
CONFIG_ATHEROS_AR2315=y
-CONFIG_ATHEROS_AR2315_PCI=y
CONFIG_ATHEROS_AR231X=y
CONFIG_ATHEROS_AR5312=y
CONFIG_CC_OPTIMIZE_FOR_SIZE=y
@@ -115,6 +114,7 @@ CONFIG_NET_RX_BUSY_POLL=y
CONFIG_NO_GENERIC_PCI_IOPORT_MAP=y
CONFIG_PAGEFLAGS_EXTENDED=y
CONFIG_PCI=y
+CONFIG_PCI_AR2315=y
CONFIG_PCI_DISABLE_COMMON_QUIRKS=y
CONFIG_PCI_DOMAINS=y
CONFIG_PERF_USE_VMALLOC=y
diff --git a/target/linux/atheros/patches-3.14/105-ar2315_pci.patch b/target/linux/atheros/patches-3.14/105-ar2315_pci.patch
index 5c437dc2c5..ab87c6a185 100644
--- a/target/linux/atheros/patches-3.14/105-ar2315_pci.patch
+++ b/target/linux/atheros/patches-3.14/105-ar2315_pci.patch
@@ -1,10 +1,11 @@
--- a/arch/mips/ar231x/Makefile
+++ b/arch/mips/ar231x/Makefile
-@@ -14,3 +14,4 @@ obj-$(CONFIG_EARLY_PRINTK) += early_prin
+@@ -14,3 +14,5 @@ obj-$(CONFIG_EARLY_PRINTK) += early_prin
obj-$(CONFIG_ATHEROS_AR5312) += ar5312.o
obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
-+obj-$(CONFIG_ATHEROS_AR2315_PCI) += pci.o
++obj-$(CONFIG_PCI_AR2315) += pci.o
++
--- /dev/null
+++ b/arch/mips/ar231x/pci.c
@@ -0,0 +1,340 @@
@@ -355,8 +356,8 @@
depends on ATHEROS_AR231X
default y
+
-+config ATHEROS_AR2315_PCI
-+ bool "PCI support"
++config PCI_AR2315
++ bool "AR2315 PCI controller support"
+ depends on ATHEROS_AR2315
+ select HW_HAS_PCI
+ select PCI
@@ -367,7 +368,7 @@
do_IRQ(AR2315_IRQ_WLAN0_INTRS);
else if (pending & CAUSEF_IP4)
do_IRQ(AR2315_IRQ_ENET0_INTRS);
-+#ifdef CONFIG_ATHEROS_AR2315_PCI
++#ifdef CONFIG_PCI_AR2315
+ else if (pending & CAUSEF_IP5)
+ do_IRQ(AR2315_IRQ_LCBUS_PCI);
+#endif