summaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-2.6.26/120-watchdog.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2008-08-14 16:08:46 +0000
committerJohn Crispin <john@openwrt.org>2008-08-14 16:08:46 +0000
commit9379dc19b6b850617763d10cf545a5533c8e6f17 (patch)
tree421be037104a7b27ff39f89a45b1c3bf1a2b6ff5 /target/linux/atheros/patches-2.6.26/120-watchdog.patch
parent58fb9f67ec9a60b808225a83dcbeeed227eb413a (diff)
downloadmaster-31e0f0ae-9379dc19b6b850617763d10cf545a5533c8e6f17.tar.gz
master-31e0f0ae-9379dc19b6b850617763d10cf545a5533c8e6f17.tar.bz2
master-31e0f0ae-9379dc19b6b850617763d10cf545a5533c8e6f17.zip
adds watchdog driver to ar5315
SVN-Revision: 12309
Diffstat (limited to 'target/linux/atheros/patches-2.6.26/120-watchdog.patch')
-rw-r--r--target/linux/atheros/patches-2.6.26/120-watchdog.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/atheros/patches-2.6.26/120-watchdog.patch b/target/linux/atheros/patches-2.6.26/120-watchdog.patch
new file mode 100644
index 0000000000..64ac6871ce
--- /dev/null
+++ b/target/linux/atheros/patches-2.6.26/120-watchdog.patch
@@ -0,0 +1,29 @@
+Index: linux-2.6.26.2/drivers/watchdog/Kconfig
+===================================================================
+--- linux-2.6.26.2.orig/drivers/watchdog/Kconfig 2008-08-14 16:54:30.000000000 +0200
++++ linux-2.6.26.2/drivers/watchdog/Kconfig 2008-08-14 16:55:40.000000000 +0200
+@@ -683,6 +683,12 @@
+ help
+ Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+
++config ATHEROS_WDT
++ tristate "Atheros wisoc Watchdog Timer"
++ depends on ATHEROS
++ help
++ Hardware driver for the Atheros wisoc Watchdog Timer.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+Index: linux-2.6.26.2/drivers/watchdog/Makefile
+===================================================================
+--- linux-2.6.26.2.orig/drivers/watchdog/Makefile 2008-08-14 16:55:44.000000000 +0200
++++ linux-2.6.26.2/drivers/watchdog/Makefile 2008-08-14 16:58:16.000000000 +0200
+@@ -97,6 +97,7 @@
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_ATHEROS_WDT) += ar2315-wtd.o
+
+ # PARISC Architecture
+