summaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-2.6.26/110-spiflash.patch
diff options
context:
space:
mode:
authorMatteo Croce <rootkit85@yahoo.it>2008-07-27 21:42:36 +0000
committerMatteo Croce <rootkit85@yahoo.it>2008-07-27 21:42:36 +0000
commit5cb5a026ee1020543270cb7c55bc4fa20128198f (patch)
tree4b36c306b12976f45ad27d2ecbd02be30e518702 /target/linux/atheros/patches-2.6.26/110-spiflash.patch
parent68f4ae4e94c2ce66733174fec9150b21fcb59c56 (diff)
downloadmaster-31e0f0ae-5cb5a026ee1020543270cb7c55bc4fa20128198f.tar.gz
master-31e0f0ae-5cb5a026ee1020543270cb7c55bc4fa20128198f.tar.bz2
master-31e0f0ae-5cb5a026ee1020543270cb7c55bc4fa20128198f.zip
atheros: 2.6.26 patches
SVN-Revision: 11965
Diffstat (limited to 'target/linux/atheros/patches-2.6.26/110-spiflash.patch')
-rw-r--r--target/linux/atheros/patches-2.6.26/110-spiflash.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/atheros/patches-2.6.26/110-spiflash.patch b/target/linux/atheros/patches-2.6.26/110-spiflash.patch
new file mode 100644
index 0000000000..527198c210
--- /dev/null
+++ b/target/linux/atheros/patches-2.6.26/110-spiflash.patch
@@ -0,0 +1,20 @@
+--- a/drivers/mtd/devices/Kconfig
++++ b/drivers/mtd/devices/Kconfig
+@@ -84,6 +84,10 @@
+ help
+ This option enables FAST_READ access supported by ST M25Pxx.
+
++config MTD_SPIFLASH
++ tristate "Atheros AR2315/6/7 SPI Flash support"
++ depends on ATHEROS_AR5315
++
+ config MTD_SLRAM
+ tristate "Uncached system RAM"
+ help
+--- a/drivers/mtd/devices/Makefile
++++ b/drivers/mtd/devices/Makefile
+@@ -17,3 +17,4 @@
+ obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd.o
+ obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
+ obj-$(CONFIG_MTD_M25P80) += m25p80.o
++obj-$(CONFIG_MTD_SPIFLASH) += spiflash.o