summaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-2.6.25/110-spiflash.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-03 05:43:29 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-03 05:43:29 +0000
commit21c5ef4c1d5cf43b8055eea98a509412c0ab17c1 (patch)
tree4528a0a88e63fb437b0e9bea548ebad14be7190a /target/linux/atheros/patches-2.6.25/110-spiflash.patch
parentfe5b22046748c8795afc6c86d9733af6e3087017 (diff)
downloadmaster-31e0f0ae-21c5ef4c1d5cf43b8055eea98a509412c0ab17c1.tar.gz
master-31e0f0ae-21c5ef4c1d5cf43b8055eea98a509412c0ab17c1.tar.bz2
master-31e0f0ae-21c5ef4c1d5cf43b8055eea98a509412c0ab17c1.zip
add .25 patches (kernel boots fine on LS2, LS5, FON2200 and on WRT55AG v2)
SVN-Revision: 11016
Diffstat (limited to 'target/linux/atheros/patches-2.6.25/110-spiflash.patch')
-rw-r--r--target/linux/atheros/patches-2.6.25/110-spiflash.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/atheros/patches-2.6.25/110-spiflash.patch b/target/linux/atheros/patches-2.6.25/110-spiflash.patch
new file mode 100644
index 0000000000..bb66f02fb5
--- /dev/null
+++ b/target/linux/atheros/patches-2.6.25/110-spiflash.patch
@@ -0,0 +1,24 @@
+Index: linux-2.6.25.1/drivers/mtd/devices/Kconfig
+===================================================================
+--- linux-2.6.25.1.orig/drivers/mtd/devices/Kconfig
++++ linux-2.6.25.1/drivers/mtd/devices/Kconfig
+@@ -77,6 +77,10 @@ config MTD_M25P80
+ if you want to specify device partitioning or to use a device which
+ doesn't support the JEDEC ID instruction.
+
++config MTD_SPIFLASH
++ tristate "Atheros AR2315/6/7 SPI Flash support"
++ depends on ATHEROS_AR5315
++
+ config MTD_SLRAM
+ tristate "Uncached system RAM"
+ help
+Index: linux-2.6.25.1/drivers/mtd/devices/Makefile
+===================================================================
+--- linux-2.6.25.1.orig/drivers/mtd/devices/Makefile
++++ linux-2.6.25.1/drivers/mtd/devices/Makefile
+@@ -17,3 +17,4 @@ obj-$(CONFIG_MTD_LART) += lart.o
+ obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd.o
+ obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
+ obj-$(CONFIG_MTD_M25P80) += m25p80.o
++obj-$(CONFIG_MTD_SPIFLASH) += spiflash.o