summaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/image/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-09-22 01:09:04 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-09-22 01:09:04 +0000
commitf20af3832204ca2c35a9f1da208a34d2a509996c (patch)
tree86d860c62728686a3eda58e7f7de3b75c5127f48 /target/linux/atheros/image/Makefile
parent5b027739405dc0f0dcee3588a17df19cae11eda9 (diff)
downloadmaster-31e0f0ae-f20af3832204ca2c35a9f1da208a34d2a509996c.tar.gz
master-31e0f0ae-f20af3832204ca2c35a9f1da208a34d2a509996c.tar.bz2
master-31e0f0ae-f20af3832204ca2c35a9f1da208a34d2a509996c.zip
Implement a preliminary combined image format. - add sysupgrade support for combined images by providing a platform.sh backend - use the mtd fis partition table rewrite facility to resize partitions on demand - generate generic combined images for the atheros target
SVN-Revision: 17668
Diffstat (limited to 'target/linux/atheros/image/Makefile')
-rw-r--r--target/linux/atheros/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
index 40044895b8..15cd995865 100644
--- a/target/linux/atheros/image/Makefile
+++ b/target/linux/atheros/image/Makefile
@@ -51,6 +51,12 @@ define Image/Build
-p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
$(BIN_DIR)/openwrt-$(BOARD)-wpe53g-$(1).bin
+ ifeq ($(BOARD),atheros)
+ -sh $(TOPDIR)/scripts/combined-image.sh \
+ "$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma" \
+ "$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)" \
+ "$(BIN_DIR)/openwrt-$(BOARD)-combined.img"
+ endif
endef
$(eval $(call BuildImage))