summaryrefslogtreecommitdiffstats
path: root/target/linux/ath25
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-08-09 17:23:56 +0200
committerJo-Philipp Wich <jo@mein.io>2016-08-09 17:28:19 +0200
commit21f460a5dbef5e3ec59e2032b5b113fe045b475f (patch)
tree532e1fb109b69ab8d914f87740446ae9956801f8 /target/linux/ath25
parent7ee92227700c324f4c7c9b587bca1d8267c29112 (diff)
downloadmaster-31e0f0ae-21f460a5dbef5e3ec59e2032b5b113fe045b475f.tar.gz
master-31e0f0ae-21f460a5dbef5e3ec59e2032b5b113fe045b475f.tar.bz2
master-31e0f0ae-21f460a5dbef5e3ec59e2032b5b113fe045b475f.zip
ath25: fix duplicate LZMA compression
The conversion to the new image building code accidentally caused the kernel image to get compressed twice, leading to boot failures when kernel and rootfs are flashed separately. The sysupgrade images have been unaffected by this. Also restore the elf kernel build artifact while we're at it. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/ath25')
-rw-r--r--target/linux/ath25/image/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/target/linux/ath25/image/Makefile b/target/linux/ath25/image/Makefile
index 4face056e3..5144ed8a0a 100644
--- a/target/linux/ath25/image/Makefile
+++ b/target/linux/ath25/image/Makefile
@@ -42,19 +42,30 @@ define Build/lzma-kernel
dd if=$@.l7 of=$@ bs=65536 conv=sync
endef
+define Build/copy-kernel
+ rm -f $@ $@.elf
+ cp $< $@
+ cp $< $@.elf
+endef
+
+define Build/elf-kernel
+ cp $(IMAGE_KERNEL).elf $@
+endef
+
define Device/Default
PROFILES = Default $$(DEVICE_NAME)
- KERNEL := kernel-bin | lzma-kernel
+ KERNEL := copy-kernel | lzma-kernel
IMAGES := sysupgrade.bin
FILESYSTEMS := squashfs
endef
define Device/generic
DEVICE_TITLE := Generic Images
- IMAGES := kernel.lzma kernel.gz rootfs.bin sysupgrade.bin
- IMAGE/kernel.gz := append-kernel | gzip-kernel
- IMAGE/kernel.lzma := append-kernel | lzma-kernel
+ IMAGES := kernel.lzma kernel.elf kernel.gz rootfs.bin sysupgrade.bin
+ IMAGE/kernel.gz := elf-kernel | gzip-kernel
+ IMAGE/kernel.elf := elf-kernel
+ IMAGE/kernel.lzma := elf-kernel | lzma-kernel
IMAGE/rootfs.bin := append-rootfs | pad-rootfs | pad-to 128k
IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | combined-image
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(if $$(findstring kernel,$$(2)),,$$(1)-)$$(2)