summaryrefslogtreecommitdiffstats
path: root/target/linux/ath25
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-14 09:57:45 +0000
committerJohn Crispin <john@openwrt.org>2015-07-14 09:57:45 +0000
commit096b3759a98cdbbc710d8620e948eaa7ee2045ed (patch)
treeddec733630e2353a6f2890b81f65410dbfdf165c /target/linux/ath25
parent3846bb9ac92060669f9c798c3c128057a6d32809 (diff)
downloadmaster-31e0f0ae-096b3759a98cdbbc710d8620e948eaa7ee2045ed.tar.gz
master-31e0f0ae-096b3759a98cdbbc710d8620e948eaa7ee2045ed.tar.bz2
master-31e0f0ae-096b3759a98cdbbc710d8620e948eaa7ee2045ed.zip
build: Prevent more gzip timestamps
To improve reproducibility, prevent the inclusion of timestamps in the gzip header. Signed-off-by: Reiner Herrmann <reiner@reiner-h.de> SVN-Revision: 46361
Diffstat (limited to 'target/linux/ath25')
-rw-r--r--target/linux/ath25/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath25/image/Makefile b/target/linux/ath25/image/Makefile
index 86f2d44bfe..6bdb3c4755 100644
--- a/target/linux/ath25/image/Makefile
+++ b/target/linux/ath25/image/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
define Image/BuildKernel
cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
- gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
+ gzip -9n -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma bs=65536 conv=sync
dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.gz bs=65536 conv=sync