summaryrefslogtreecommitdiffstats
path: root/target/linux/ath25/profiles
diff options
context:
space:
mode:
authorRussell Senior <russell@personaltelco.net>2016-05-16 00:52:24 -0700
committerJohn Crispin <john@phrozen.org>2016-05-23 11:56:38 +0200
commitf89a20a89aebe4767c606b4e04a6a3906e1ee26c (patch)
tree87d0ae9a08aa7b42cad3d2fe9cb632211d834ff9 /target/linux/ath25/profiles
parentc7efbd7dbb29238631efb7e8565c507284877644 (diff)
downloadmaster-31e0f0ae-f89a20a89aebe4767c606b4e04a6a3906e1ee26c.tar.gz
master-31e0f0ae-f89a20a89aebe4767c606b4e04a6a3906e1ee26c.tar.bz2
master-31e0f0ae-f89a20a89aebe4767c606b4e04a6a3906e1ee26c.zip
ath25: update kernel from 3.18 to 4.4
Summary of changes: * moved config-3.18 to config-4.4 and patches-3.18 to patches-4.4 * removed most of the first two patches, that seem to be upstream already * changed deprecated/removed IRQF_DISABLED to zero following examples in upstream kernel patches * added config line to disable device-tree to satisfy kernel configuration * add new image generation code Build tested and run tested on an Accton MR3201A. Signed-off-by: Russell Senior <russell@personaltelco.net> Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ath25/profiles')
-rw-r--r--target/linux/ath25/profiles/00-default.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath25/profiles/00-default.mk b/target/linux/ath25/profiles/00-default.mk
new file mode 100644
index 0000000000..b40eb1b0ce
--- /dev/null
+++ b/target/linux/ath25/profiles/00-default.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))