summaryrefslogtreecommitdiffstats
path: root/target/linux/ath25/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-13 03:02:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-13 03:02:28 +0000
commit1850e0f0a7627b4e0ef18516ff2b25a7c14215ca (patch)
tree22c612d44a744058d16d50acce527f0d07c9151b /target/linux/ath25/Makefile
parent558a452e1a50f6195c8839c9828ae94a89ea0308 (diff)
downloadmaster-31e0f0ae-1850e0f0a7627b4e0ef18516ff2b25a7c14215ca.tar.gz
master-31e0f0ae-1850e0f0a7627b4e0ef18516ff2b25a7c14215ca.tar.bz2
master-31e0f0ae-1850e0f0a7627b4e0ef18516ff2b25a7c14215ca.zip
Rename 'atheros' target to 'ath25'
Rename 'atheros' target to more precise 'ath25'. Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> SVN-Revision: 44736
Diffstat (limited to 'target/linux/ath25/Makefile')
-rw-r--r--target/linux/ath25/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ath25/Makefile b/target/linux/ath25/Makefile
new file mode 100644
index 0000000000..b1baa2e6b0
--- /dev/null
+++ b/target/linux/ath25/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=ath25
+BOARDNAME:=Atheros AR231x/AR5312
+FEATURES:=squashfs low_mem
+
+KERNEL_PATCHVER:=3.18
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
+
+define Target/Description
+ Build firmware images for Atheros SoC boards
+endef
+
+$(eval $(call BuildTarget))