summaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-13 11:55:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-13 11:55:24 +0000
commitd34e2a337c136432c0058b5bd8b62c71a689a732 (patch)
tree8b9c3591ea9a31d95ec51cd83cab117a93490acd /target/linux/at91
parent45380ebd1ab3d604ece3dd14a84f89fbc69ea7b1 (diff)
downloadmaster-31e0f0ae-d34e2a337c136432c0058b5bd8b62c71a689a732.tar.gz
master-31e0f0ae-d34e2a337c136432c0058b5bd8b62c71a689a732.tar.bz2
master-31e0f0ae-d34e2a337c136432c0058b5bd8b62c71a689a732.zip
at91: remove linux 3.10 support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43688
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/files-3.10/arch/arm/boot/dts/lmu5000.dts125
-rw-r--r--target/linux/at91/files-3.10/drivers/mtd/at91part.c122
-rw-r--r--target/linux/at91/patches-3.10/100-ARM-at91-build-dtb-for-LMU5000.patch10
-rw-r--r--target/linux/at91/patches-3.10/805-free_some_portc_pins.patch11
-rw-r--r--target/linux/at91/patches-3.10/901-AT91-flexibity-default-leds-to-heartbeat.patch60
5 files changed, 0 insertions, 328 deletions
diff --git a/target/linux/at91/files-3.10/arch/arm/boot/dts/lmu5000.dts b/target/linux/at91/files-3.10/arch/arm/boot/dts/lmu5000.dts
deleted file mode 100644
index 671f452416..0000000000
--- a/target/linux/at91/files-3.10/arch/arm/boot/dts/lmu5000.dts
+++ /dev/null
@@ -1,125 +0,0 @@
-/*
- * lmu5000.dst - Device Tree file for CalAmp LMU5000 board
- *
- * Copyright (C) 2013 Adam Porter <porter.adam@gmail.com>
- *
- * Licensed under GPLv2.
- */
-/dts-v1/;
-/include/ "at91sam9g20.dtsi"
-
-/ {
- model = "CalAmp LMU5000";
- compatible = "calamp,lmu5000", "atmel,at91sam9g20", "atmel,at91sam9";
-
- chosen {
- bootargs = "mem=64M console=ttyS0,115200 rootfstype=jffs2";
- };
-
- memory {
- reg = <0x20000000 0x4000000>;
- };
-
- clocks {
- #address-cells = <1>;
- #size-cells = <1>;
- ranges;
-
- main_clock: clock@0 {
- compatible = "atmel,osc", "fixed-clock";
- clock-frequency = <18432000>;
- };
- };
-
- ahb {
- apb {
- pinctrl@fffff400 {
- board {
- pinctrl_pck0_as_mck: pck0_as_mck {
- atmel,pins =
- <2 1 0x2 0x0>; /* PC1 periph B */
- };
-
- };
- };
-
- dbgu: serial@fffff200 {
- status = "okay";
- };
-
- usart0: serial@fffb0000 {
- pinctrl-0 =
- <&pinctrl_usart0
- &pinctrl_usart0_rts
- &pinctrl_usart0_cts
- &pinctrl_usart0_dtr_dsr
- &pinctrl_usart0_dcd
- &pinctrl_usart0_ri>;
- status = "okay";
- };
-
- usart2: serial@fffb8000 {
- status = "okay";
- };
-
- uart0: serial@fffd4000 {
- status = "okay";
- };
-
- uart1: serial@fffd8000 {
- status = "okay";
- };
-
- macb0: ethernet@fffc4000 {
- phy-mode = "mii";
- status = "okay";
- };
-
- usb1: gadget@fffa4000 {
- atmel,vbus-gpio = <&pioC 5 0>;
- status = "okay";
- };
-
- ssc0: ssc@fffbc000 {
- status = "okay";
- pinctrl-0 = <&pinctrl_ssc0_tx>;
- };
-
- watchdog@fffffd40 {
- status = "okay";
- };
- };
-
- nand0: nand@40000000 {
- nand-bus-width = <8>;
- nand-ecc-mode = "soft";
- nand-on-flash-bbt;
- status = "okay";
-
- kernel@0 {
- label = "kernel";
- reg = <0x0 0x400000>;
- };
-
- rootfs@400000 {
- label = "rootfs";
- reg = <0x400000 0x3C00000>;
- };
-
- user1@4000000 {
- label = "user1";
- reg = <0x4000000 0x2000000>;
- };
-
- user2@6000000 {
- label = "user2";
- reg = <0x6000000 0x2000000>;
- };
- };
-
- usb0: ohci@00500000 {
- num-ports = <2>;
- status = "okay";
- };
- };
-};
diff --git a/target/linux/at91/files-3.10/drivers/mtd/at91part.c b/target/linux/at91/files-3.10/drivers/mtd/at91part.c
deleted file mode 100644
index 31f3bbd69d..0000000000
--- a/target/linux/at91/files-3.10/drivers/mtd/at91part.c
+++ /dev/null
@@ -1,122 +0,0 @@
-/*
- *
- * Copyright (C) 2007 OpenWrt.org
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
- *
- * Atmel AT91 flash partition table. (Modified by Hamish Guthrie).
- * Based on ar7 map by Felix Fietkau.
- *
- */
-
-#include <linux/kernel.h>
-#include <linux/slab.h>
-
-#include <linux/mtd/mtd.h>
-#include <linux/mtd/partitions.h>
-#include <linux/bootmem.h>
-#include <linux/squashfs_fs.h>
-
-static struct mtd_partition at91_parts[6];
-
-static int create_mtd_partitions(struct mtd_info *master,
- struct mtd_partition **pparts,
- unsigned long origin)
-{
- unsigned int offset, len;
- unsigned int pre_size = 0x42000, root_max = 0x362400;
- unsigned char buf[512];
- struct squashfs_super_block *sb = (struct squashfs_super_block *) buf;
-
- printk("Parsing AT91 partition map...\n");
-
- at91_parts[0].name = "loaders";
- at91_parts[0].offset = 0;
- at91_parts[0].size = 0x21000;
- at91_parts[0].mask_flags = MTD_WRITEABLE;
-
- at91_parts[1].name = "ubparams";
- at91_parts[1].offset = 0x21000;
- at91_parts[1].size = 0x8400;
- at91_parts[1].mask_flags = 0;
-
- at91_parts[2].name = "kernel";
- at91_parts[2].offset = pre_size;
- at91_parts[2].size = 0;
- at91_parts[2].mask_flags = 0;
-
- at91_parts[3].name = "rootfs";
- at91_parts[3].offset = 0;
- at91_parts[3].size = 0;
- at91_parts[3].mask_flags = 0;
-
- for(offset = pre_size; offset < root_max; offset += master->erasesize) {
-
- memset(&buf, 0xe5, sizeof(buf));
-
- if (master->read(master, offset, sizeof(buf), &len, buf) || len != sizeof(buf))
- break;
-
- if (*((__u32 *) buf) == SQUASHFS_MAGIC) {
- printk(KERN_INFO "%s: Filesystem type: squashfs, size=0x%x\n",
- master->name, (u32) sb->bytes_used);
-
- at91_parts[3].size = sb->bytes_used;
- at91_parts[3].offset = offset;
- len = at91_parts[3].offset + at91_parts[3].size;
- len = ((len / (master->erasesize * 8)) + 1) * master->erasesize * 8;
- at91_parts[3].size = len - at91_parts[3].offset;
- at91_parts[2].size = offset - at91_parts[2].offset;
- break;
- }
- }
-
- if (at91_parts[3].size == 0) {
- printk(KERN_NOTICE "%s: Couldn't find root filesystem\n", master->name);
- return -1;
- }
-
- at91_parts[4].name = "rootfs_data";
- at91_parts[4].offset = root_max;
- at91_parts[4].size = master->size - root_max;
- at91_parts[4].mask_flags = 0;
-
- at91_parts[5].name = "complete";
- at91_parts[5].offset = 0;
- at91_parts[5].size = master->size;
- at91_parts[5].mask_flags = 0;
-
- *pparts = at91_parts;
- return 6;
-}
-
-static struct mtd_part_parser at91_parser = {
- .owner = THIS_MODULE,
- .parse_fn = create_mtd_partitions,
- .name = "at91part",
-};
-
-static int __init at91_parser_init(void)
-{
- register_mtd_parser(&at91_parser);
-
- return 0;
-}
-
-module_init(at91_parser_init);
-
-MODULE_LICENSE("GPL");
-MODULE_AUTHOR("Felix Fietkau, Eugene Konev, Hamish Guthrie");
-MODULE_DESCRIPTION("MTD partitioning for Atmel at91");
diff --git a/target/linux/at91/patches-3.10/100-ARM-at91-build-dtb-for-LMU5000.patch b/target/linux/at91/patches-3.10/100-ARM-at91-build-dtb-for-LMU5000.patch
deleted file mode 100644
index c631f8d588..0000000000
--- a/target/linux/at91/patches-3.10/100-ARM-at91-build-dtb-for-LMU5000.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -23,6 +23,7 @@ dtb-$(CONFIG_ARCH_AT91) += tny_a9g20.dtb
- dtb-$(CONFIG_ARCH_AT91) += usb_a9g20.dtb
- # sam9g45
- dtb-$(CONFIG_ARCH_AT91) += at91sam9m10g45ek.dtb
-+dtb-$(CONFIG_ARCH_AT91) += lmu5000.dtb
- dtb-$(CONFIG_ARCH_AT91) += pm9g45.dtb
- # sam9n12
- dtb-$(CONFIG_ARCH_AT91) += at91sam9n12ek.dtb
diff --git a/target/linux/at91/patches-3.10/805-free_some_portc_pins.patch b/target/linux/at91/patches-3.10/805-free_some_portc_pins.patch
deleted file mode 100644
index a9694d1f01..0000000000
--- a/target/linux/at91/patches-3.10/805-free_some_portc_pins.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/arm/mach-at91/at91sam9260_devices.c
-+++ b/arch/arm/mach-at91/at91sam9260_devices.c
-@@ -507,7 +507,7 @@ static struct platform_device at91sam926
- .num_resources = ARRAY_SIZE(spi1_resources),
- };
-
--static const unsigned spi1_standard_cs[4] = { AT91_PIN_PB3, AT91_PIN_PC5, AT91_PIN_PC4, AT91_PIN_PC3 };
-+static const unsigned spi1_standard_cs[2] = { AT91_PIN_PB3, AT91_PIN_PC5 };
-
- void __init at91_add_device_spi(struct spi_board_info *devices, int nr_devices)
- {
diff --git a/target/linux/at91/patches-3.10/901-AT91-flexibity-default-leds-to-heartbeat.patch b/target/linux/at91/patches-3.10/901-AT91-flexibity-default-leds-to-heartbeat.patch
deleted file mode 100644
index a97850ac91..0000000000
--- a/target/linux/at91/patches-3.10/901-AT91-flexibity-default-leds-to-heartbeat.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- a/arch/arm/mach-at91/board-flexibity.c
-+++ b/arch/arm/mach-at91/board-flexibity.c
-@@ -89,49 +89,49 @@ static struct gpio_led flexibity_leds[]
- .name = "usb1:green",
- .gpio = AT91_PIN_PA12,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb1:red",
- .gpio = AT91_PIN_PA13,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb2:green",
- .gpio = AT91_PIN_PB26,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb2:red",
- .gpio = AT91_PIN_PB27,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb3:green",
- .gpio = AT91_PIN_PC8,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb3:red",
- .gpio = AT91_PIN_PC6,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb4:green",
- .gpio = AT91_PIN_PB4,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb4:red",
- .gpio = AT91_PIN_PB5,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- }
- };
-