summaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-28 13:25:21 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-28 13:25:21 +0000
commitba9f34a38981305e95b0b84df717acdd89d5c27a (patch)
tree7797847a10c9d80a080f601d08dc7051b4060d6e /target/linux/at91
parentd7f6b8e3bead839ccf3b253c5b846f673348a12e (diff)
downloadmaster-31e0f0ae-ba9f34a38981305e95b0b84df717acdd89d5c27a.tar.gz
master-31e0f0ae-ba9f34a38981305e95b0b84df717acdd89d5c27a.tar.bz2
master-31e0f0ae-ba9f34a38981305e95b0b84df717acdd89d5c27a.zip
at91: fix imagebuilder
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 45806
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 49e2bee5c1..4e472f23db 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -24,6 +24,7 @@ define Build/Compile
endef
define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/Image $(KDIR)/Image
cp $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/zImage
endef
@@ -89,9 +90,9 @@ endef
define Image/BuildKernel
mkimage -A arm -T kernel -C none -a 0x20008000 -e 0x20008000 -n linux-2.6 \
- -d $(LINUX_DIR)/arch/arm/boot/Image $(BIN_DIR)/uImage
+ -d $(KDIR)/Image $(BIN_DIR)/$(IMG_PREFIX)-uImage
if [ $(CONFIG_FLEXIBITY_ROOT) ]; then \
- $(INSTALL_BIN) $(BIN_DIR)/uImage $(TARGET_DIR)/uImage ; \
+ $(INSTALL_BIN) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/uImage ; \
fi
$(call Image/Build/Kernel/$(PROFILE))
endef