summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/patches-3.10
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-09-03 03:09:51 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-09-03 03:09:51 +0000
commit035f68e8587800c5c9a9d2a7cbeb44a4afeb85e4 (patch)
tree98fa1164ff1957955e58915e7874e38a4ecebc41 /target/linux/at91/patches-3.10
parent132676f1ac6c9745f44a7a16e2c61ece5483c440 (diff)
downloadmaster-31e0f0ae-035f68e8587800c5c9a9d2a7cbeb44a4afeb85e4.tar.gz
master-31e0f0ae-035f68e8587800c5c9a9d2a7cbeb44a4afeb85e4.tar.bz2
master-31e0f0ae-035f68e8587800c5c9a9d2a7cbeb44a4afeb85e4.zip
at91: move 3.10 specific files and patches
In preparation for adding 3.14 kernel support, move files and patches to a separate per-version directory since some of them will have incompatible changes (e.g: dts) Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 42413
Diffstat (limited to 'target/linux/at91/patches-3.10')
-rw-r--r--target/linux/at91/patches-3.10/100-ARM-at91-build-dtb-for-LMU5000.patch10
-rw-r--r--target/linux/at91/patches-3.10/700-tqma9263-support.patch25
-rw-r--r--target/linux/at91/patches-3.10/805-free_some_portc_pins.patch11
-rw-r--r--target/linux/at91/patches-3.10/901-AT91-flexibity-default-leds-to-heartbeat.patch60
4 files changed, 106 insertions, 0 deletions
diff --git a/target/linux/at91/patches-3.10/100-ARM-at91-build-dtb-for-LMU5000.patch b/target/linux/at91/patches-3.10/100-ARM-at91-build-dtb-for-LMU5000.patch
new file mode 100644
index 0000000000..c631f8d588
--- /dev/null
+++ b/target/linux/at91/patches-3.10/100-ARM-at91-build-dtb-for-LMU5000.patch
@@ -0,0 +1,10 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -23,6 +23,7 @@ dtb-$(CONFIG_ARCH_AT91) += tny_a9g20.dtb
+ dtb-$(CONFIG_ARCH_AT91) += usb_a9g20.dtb
+ # sam9g45
+ dtb-$(CONFIG_ARCH_AT91) += at91sam9m10g45ek.dtb
++dtb-$(CONFIG_ARCH_AT91) += lmu5000.dtb
+ dtb-$(CONFIG_ARCH_AT91) += pm9g45.dtb
+ # sam9n12
+ dtb-$(CONFIG_ARCH_AT91) += at91sam9n12ek.dtb
diff --git a/target/linux/at91/patches-3.10/700-tqma9263-support.patch b/target/linux/at91/patches-3.10/700-tqma9263-support.patch
new file mode 100644
index 0000000000..d249783a3e
--- /dev/null
+++ b/target/linux/at91/patches-3.10/700-tqma9263-support.patch
@@ -0,0 +1,25 @@
+--- a/arch/arm/mach-at91/Kconfig.non_dt
++++ b/arch/arm/mach-at91/Kconfig.non_dt
+@@ -258,6 +258,12 @@ config MACH_USB_A9263
+ Select this if you are using a Calao Systems USB-A9263.
+ <http://www.calao-systems.com>
+
++config MACH_TQMA9263
++ bool "TQ Components TQMa9263 board"
++ help
++ Select this if you are using the an TQ Components TQMa9263 board.
++ <http://www.tq-components.com/>
++
+ endif
+
+ # ----------------------------------------------------------
+--- a/arch/arm/mach-at91/Makefile
++++ b/arch/arm/mach-at91/Makefile
+@@ -68,6 +68,7 @@ obj-$(CONFIG_MACH_AT91SAM9G10EK) += boar
+ # AT91SAM9263 board-specific support
+ obj-$(CONFIG_MACH_AT91SAM9263EK) += board-sam9263ek.o
+ obj-$(CONFIG_MACH_USB_A9263) += board-usb-a926x.o
++obj-$(CONFIG_MACH_TQMA9263) += board-tqma9263.o
+
+ # AT91SAM9RL board-specific support
+ obj-$(CONFIG_MACH_AT91SAM9RLEK) += board-sam9rlek.o
diff --git a/target/linux/at91/patches-3.10/805-free_some_portc_pins.patch b/target/linux/at91/patches-3.10/805-free_some_portc_pins.patch
new file mode 100644
index 0000000000..a9694d1f01
--- /dev/null
+++ b/target/linux/at91/patches-3.10/805-free_some_portc_pins.patch
@@ -0,0 +1,11 @@
+--- a/arch/arm/mach-at91/at91sam9260_devices.c
++++ b/arch/arm/mach-at91/at91sam9260_devices.c
+@@ -507,7 +507,7 @@ static struct platform_device at91sam926
+ .num_resources = ARRAY_SIZE(spi1_resources),
+ };
+
+-static const unsigned spi1_standard_cs[4] = { AT91_PIN_PB3, AT91_PIN_PC5, AT91_PIN_PC4, AT91_PIN_PC3 };
++static const unsigned spi1_standard_cs[2] = { AT91_PIN_PB3, AT91_PIN_PC5 };
+
+ void __init at91_add_device_spi(struct spi_board_info *devices, int nr_devices)
+ {
diff --git a/target/linux/at91/patches-3.10/901-AT91-flexibity-default-leds-to-heartbeat.patch b/target/linux/at91/patches-3.10/901-AT91-flexibity-default-leds-to-heartbeat.patch
new file mode 100644
index 0000000000..a97850ac91
--- /dev/null
+++ b/target/linux/at91/patches-3.10/901-AT91-flexibity-default-leds-to-heartbeat.patch
@@ -0,0 +1,60 @@
+--- a/arch/arm/mach-at91/board-flexibity.c
++++ b/arch/arm/mach-at91/board-flexibity.c
+@@ -89,49 +89,49 @@ static struct gpio_led flexibity_leds[]
+ .name = "usb1:green",
+ .gpio = AT91_PIN_PA12,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb1:red",
+ .gpio = AT91_PIN_PA13,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb2:green",
+ .gpio = AT91_PIN_PB26,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb2:red",
+ .gpio = AT91_PIN_PB27,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb3:green",
+ .gpio = AT91_PIN_PC8,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb3:red",
+ .gpio = AT91_PIN_PC6,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb4:green",
+ .gpio = AT91_PIN_PB4,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb4:red",
+ .gpio = AT91_PIN_PB5,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ }
+ };
+