summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/modules.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-04-26 16:55:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-04-26 16:55:40 +0000
commit988ae9cbf8efbb2050a34e61b5518d93f41cb606 (patch)
tree9882e6361a7022fdcbda24f4587b0a423a53397d /target/linux/at91/modules.mk
parentc63bb1a18e04c1b72f18bf0b77491933818d08d0 (diff)
downloadmaster-31e0f0ae-988ae9cbf8efbb2050a34e61b5518d93f41cb606.tar.gz
master-31e0f0ae-988ae9cbf8efbb2050a34e61b5518d93f41cb606.tar.bz2
master-31e0f0ae-988ae9cbf8efbb2050a34e61b5518d93f41cb606.zip
at91: upgrade to kernel 3.8.7 and use devicetree
This upgrades the AT91 target to 3.8.7, and migrates to device tree. This allows a single kernel to be built for most at91 variants which simplifies things quite a bit. The immediate result is that all subtargets are nuked, and any boards without dts files are no longer supported, though the target now includes more boards than before. The adc driver was also nuked as 3.8.7 includes a new one under the IIO subsystem. Signed-off-by: Adam Porter <porter.adam@gmail.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 36452
Diffstat (limited to 'target/linux/at91/modules.mk')
-rw-r--r--target/linux/at91/modules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/at91/modules.mk b/target/linux/at91/modules.mk
index 3f20bb8a44..7866e5fd82 100644
--- a/target/linux/at91/modules.mk
+++ b/target/linux/at91/modules.mk
@@ -40,7 +40,7 @@ define KernelPackage/at91-adc
TITLE:=ADC on atmel SoC
DEPENDS:=@TARGET_at91
KCONFIG:=CONFIG_AT91_ADC
- FILES:=$(LINUX_DIR)/drivers/misc/at91-adc.ko
+ FILES:=$(LINUX_DIR)/drivers/iio/adc/at91-adc.ko
AUTOLOAD:=$(call AutoLoad,40,at91-adc)
endef