summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/modules.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-24 13:34:51 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-24 13:34:51 +0000
commit484051d05518b1f7fb53b535e84302849080272d (patch)
treed4fcbe83d1ea442b9b0a2470e95fc222536a114c /target/linux/at91/modules.mk
parent9ae19dcf8799314a89c7eabd57304c046f50d513 (diff)
downloadmaster-31e0f0ae-484051d05518b1f7fb53b535e84302849080272d.tar.gz
master-31e0f0ae-484051d05518b1f7fb53b535e84302849080272d.tar.bz2
master-31e0f0ae-484051d05518b1f7fb53b535e84302849080272d.zip
package/kernel: move target specific modules to their own target files
SVN-Revision: 21132
Diffstat (limited to 'target/linux/at91/modules.mk')
-rw-r--r--target/linux/at91/modules.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/at91/modules.mk b/target/linux/at91/modules.mk
new file mode 100644
index 0000000000..48cdef199a
--- /dev/null
+++ b/target/linux/at91/modules.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/mmc-at91
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=MMC/SD Card Support on AT91
+ DEPENDS:=@TARGET_at91 +kmod-mmc
+ KCONFIG:=CONFIG_MMC_AT91
+ FILES:=$(LINUX_DIR)/drivers/mmc/host/at91_mci.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,90,at91_mci,1)
+endef
+
+define KernelPackage/mmc-at91/description
+ Kernel support for MMC/SD cards on the AT91 target
+endef
+
+$(eval $(call KernelPackage,mmc-at91))