summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2014-04-29 21:02:05 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2014-04-29 21:02:05 +0000
commitb5f9e1632bbd2b88c927543cbc0025f4d0c41165 (patch)
treeb1ad8860b6b82d3f6bc6c9e52c9bb476ac244f78 /target/linux/at91/image
parentf6cd23364b022108bf565dc3ef7173719765f167 (diff)
downloadmaster-31e0f0ae-b5f9e1632bbd2b88c927543cbc0025f4d0c41165.tar.gz
master-31e0f0ae-b5f9e1632bbd2b88c927543cbc0025f4d0c41165.tar.bz2
master-31e0f0ae-b5f9e1632bbd2b88c927543cbc0025f4d0c41165.zip
at91: AT91SAM9G20-EK fixes
From 272f548fe8d0b811e0589e535f650f0507f6bccd Mon Sep 17 00:00:00 2001 From: Owen Kirby <osk@exegin.com> Date: Fri, 11 Apr 2014 17:59:55 -0700 Subject: [PATCH 2/3] [at91] AT91SAM9G20-EK fixes. While testing the 3.10 kernel update, I found that the out-of-the-box device tree for the the AT91SAM9G20EK uses a UBIFS rootfs and stores the DTB separately from the zImage. Signed-off-by: Owen Kirby <osk@exegin.com> SVN-Revision: 40597
Diffstat (limited to 'target/linux/at91/image')
-rw-r--r--target/linux/at91/image/Makefile12
-rw-r--r--target/linux/at91/image/ubinize.cfg13
2 files changed, 23 insertions, 2 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index cf175ab2e2..5c2f976446 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -7,6 +7,9 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+UBIFS_OPTS = -F -m 2048 -e 126KiB -c 2048 -U
+UBI_OPTS = -m 2048 -p 128KiB -s 512
+
define Build/Clean
$(MAKE) -C u-boot clean
endef
@@ -28,11 +31,16 @@ define MkuImageDtb
-d $(KDIR)/zImage-$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-uImage
endef
+define MkOftree
+ cp -u $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+ cp $(LINUX_DIR)/arch/arm/boot/dts/$(2).dtb $(BIN_DIR)/$(IMG_PREFIX)-$(1)-oftree.dtb
+endef
+
# Atmel
Image/Build/Kernel/AT91SAM9263EK=$(call MkuImageDtb,9263ek,at91sam9263ek)
Image/Build/Kernel/AT91SAM9G15EK=$(call MkuImageDtb,9g15ek,at91sam9g15ek)
-Image/Build/Kernel/AT91SAM9G20EK=$(call MkuImageDtb,9g20ek,at91sam9g20ek)
-Image/Build/Kernel/AT91SAM9G20EK-2MMC=$(call MkuImageDtb,9g20ek_2mmc,at91sam9g20ek_2mmc)
+Image/Build/Kernel/AT91SAM9G20EK=$(call MkOftree,9g20ek,at91sam9g20ek)
+Image/Build/Kernel/AT91SAM9G20EK-2MMC=$(call MkOftree,9g20ek_2mmc,at91sam9g20ek_2mmc)
Image/Build/Kernel/AT91SAM9G25EK=$(call MkuImageDtb,9g25ek,at91sam9g25ek)
Image/Build/Kernel/AT91SAM9G35EK=$(call MkuImageDtb,9g35ek,at91sam9g35ek)
Image/Build/Kernel/AT91SAM9M10G45EK=$(call MkuImageDtb,9m10g45ek,at91sam9m10g45ek)
diff --git a/target/linux/at91/image/ubinize.cfg b/target/linux/at91/image/ubinize.cfg
new file mode 100644
index 0000000000..e4149ec7d7
--- /dev/null
+++ b/target/linux/at91/image/ubinize.cfg
@@ -0,0 +1,13 @@
+[rootfs]
+# Volume mode (other option is static)
+mode=ubi
+# Source image
+image=root.ubifs
+# Volume ID in UBI image
+vol_id=0
+# Allow for dynamic resize
+vol_type=dynamic
+# Volume name
+vol_name=rootfs
+# Autoresize volume at first mount
+vol_flags=autoresize