summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-07-03 18:51:59 +0000
committerJohn Crispin <john@openwrt.org>2011-07-03 18:51:59 +0000
commit349e97f87939460050352725ff6c6be6962aa2ab (patch)
tree7556f537aea717db2b0d9087fff776210c500869 /target/linux/at91/image
parent2975f0aaf17e1d38f6f9eab57260c23ffba0545c (diff)
downloadmaster-31e0f0ae-349e97f87939460050352725ff6c6be6962aa2ab.tar.gz
master-31e0f0ae-349e97f87939460050352725ff6c6be6962aa2ab.tar.bz2
master-31e0f0ae-349e97f87939460050352725ff6c6be6962aa2ab.zip
AT91: Add flexibity board support
The patch below adds AT91 Flexibity Connect board support. Signed-off-by: Maxim Osipov <maxim.osipov@gmail.com> SVN-Revision: 27412
Diffstat (limited to 'target/linux/at91/image')
-rw-r--r--target/linux/at91/image/Config.in5
-rw-r--r--target/linux/at91/image/Makefile3
2 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/at91/image/Config.in b/target/linux/at91/image/Config.in
index ed1a52b01e..917398f269 100644
--- a/target/linux/at91/image/Config.in
+++ b/target/linux/at91/image/Config.in
@@ -30,3 +30,8 @@ config UBOOT_SERVERIP
help
IP address of TFTP server for U-Boot
+config FLEXIBITY_ROOT
+ bool "Build Flexibity RootFS (with embedded kernel)"
+ depends TARGET_at91_flexibity
+ default n
+
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 77b8b4bf60..c50732c0c4 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -23,6 +23,9 @@ endef
define Image/BuildKernel
mkimage -A arm -T kernel -C none -a 0x20008000 -e 0x20008000 -n linux-2.6 \
-d $(LINUX_DIR)/arch/arm/boot/Image $(BIN_DIR)/$(IMG_PREFIX)-uImage
+ if [ $(CONFIG_FLEXIBITY_ROOT) ]; then \
+ $(INSTALL_BIN) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/uImage ; \
+ fi
endef
define Image/Build