summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-10 23:08:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-10 23:08:11 +0000
commit1bca0cc51704b5ef57c5e3a9d7a1b80633486d16 (patch)
tree44d959af03ba5f4cf55929b6d930439b6335d0c4 /target/linux/at91/image
parentf8d965201b053be42f7690a75fd0a529608c5af3 (diff)
downloadmaster-31e0f0ae-1bca0cc51704b5ef57c5e3a9d7a1b80633486d16.tar.gz
master-31e0f0ae-1bca0cc51704b5ef57c5e3a9d7a1b80633486d16.tar.bz2
master-31e0f0ae-1bca0cc51704b5ef57c5e3a9d7a1b80633486d16.zip
make the image filenames a bit shorter
SVN-Revision: 9533
Diffstat (limited to 'target/linux/at91/image')
-rw-r--r--target/linux/at91/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 7e855f06ef..c0239ea050 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -30,14 +30,14 @@ define Image/Prepare
endef
define Image/BuildKernel
- cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
endef
define Image/Build
dd if=$(KDIR)/uImage of=$(KDIR)/uImage.block bs=8448 conv=sync
dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.block bs=8448 conv=sync
cat $(KDIR)/uImage.block $(KDIR)/root.block > $(KDIR)/knlroot.bin
- $(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/dfboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
+ $(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD).trx -f $(KDIR)/dfboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
cp $(KDIR)/dfbptest.bin $(BIN_DIR)
$(call Image/Build/$(1),$(1))
endef