summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-04-26 16:55:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-04-26 16:55:40 +0000
commit988ae9cbf8efbb2050a34e61b5518d93f41cb606 (patch)
tree9882e6361a7022fdcbda24f4587b0a423a53397d /target/linux/at91/Makefile
parentc63bb1a18e04c1b72f18bf0b77491933818d08d0 (diff)
downloadmaster-31e0f0ae-988ae9cbf8efbb2050a34e61b5518d93f41cb606.tar.gz
master-31e0f0ae-988ae9cbf8efbb2050a34e61b5518d93f41cb606.tar.bz2
master-31e0f0ae-988ae9cbf8efbb2050a34e61b5518d93f41cb606.zip
at91: upgrade to kernel 3.8.7 and use devicetree
This upgrades the AT91 target to 3.8.7, and migrates to device tree. This allows a single kernel to be built for most at91 variants which simplifies things quite a bit. The immediate result is that all subtargets are nuked, and any boards without dts files are no longer supported, though the target now includes more boards than before. The adc driver was also nuked as 3.8.7 includes a new one under the IIO subsystem. Signed-off-by: Adam Porter <porter.adam@gmail.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 36452
Diffstat (limited to 'target/linux/at91/Makefile')
-rw-r--r--target/linux/at91/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/target/linux/at91/Makefile b/target/linux/at91/Makefile
index 3c7d85bda7..10b91cc143 100644
--- a/target/linux/at91/Makefile
+++ b/target/linux/at91/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -12,14 +12,11 @@ MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
BOARDNAME:=Atmel AT91
FEATURES:=squashfs jffs2 targz ext2 usb
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
-SUBTARGETS:=9g20 9260 9263
-LINUX_VERSION:=3.3.8
-DEVICE_TYPE=
+LINUX_VERSION:=3.8.7
include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+= kmod-usb-ohci
-KERNELNAME:="uImage"
+DEFAULT_PACKAGES += kmod-usb-ohci
$(eval $(call BuildTarget))