summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/Makefile
diff options
context:
space:
mode:
authorClaudio Mignanti <c.mignanti@gmail.com>2010-06-18 22:12:33 +0000
committerClaudio Mignanti <c.mignanti@gmail.com>2010-06-18 22:12:33 +0000
commit4bb7ab3057cc4d19924034f92a0a22decba04796 (patch)
tree3904b431b529f5208069ad9dd61d448746234f67 /target/linux/at91/Makefile
parent7bff9c01010f5c8ba3147da4feffff477eccb164 (diff)
downloadmaster-31e0f0ae-4bb7ab3057cc4d19924034f92a0a22decba04796.tar.gz
master-31e0f0ae-4bb7ab3057cc4d19924034f92a0a22decba04796.tar.bz2
master-31e0f0ae-4bb7ab3057cc4d19924034f92a0a22decba04796.zip
revamp target: add support for netusg20 board
SVN-Revision: 21838
Diffstat (limited to 'target/linux/at91/Makefile')
-rw-r--r--target/linux/at91/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/target/linux/at91/Makefile b/target/linux/at91/Makefile
index 70a6082623..2f86b311d0 100644
--- a/target/linux/at91/Makefile
+++ b/target/linux/at91/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,17 +8,19 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=at91
-BOARDNAME:=Atmel AT91
-FEATURES:=squashfs usb broken
+BOARDNAME:=NetusG20
+FEATURES:=squashfs jffs2 tgz
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
-LINUX_VERSION:=2.6.25.20
+LINUX_VERSION:=2.6.34
+DEVICE_TYPE=
include $(INCLUDE_DIR)/target.mk
KERNELNAME:="uImage"
define Target/Description
- Build fimware images for Figment Design Labs VersaLink board.
+ Build firmware images for Acmesystems NetusG20 board
endef
$(eval $(call BuildTarget))