summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/9260
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-04-26 16:55:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-04-26 16:55:40 +0000
commit988ae9cbf8efbb2050a34e61b5518d93f41cb606 (patch)
tree9882e6361a7022fdcbda24f4587b0a423a53397d /target/linux/at91/9260
parentc63bb1a18e04c1b72f18bf0b77491933818d08d0 (diff)
downloadmaster-31e0f0ae-988ae9cbf8efbb2050a34e61b5518d93f41cb606.tar.gz
master-31e0f0ae-988ae9cbf8efbb2050a34e61b5518d93f41cb606.tar.bz2
master-31e0f0ae-988ae9cbf8efbb2050a34e61b5518d93f41cb606.zip
at91: upgrade to kernel 3.8.7 and use devicetree
This upgrades the AT91 target to 3.8.7, and migrates to device tree. This allows a single kernel to be built for most at91 variants which simplifies things quite a bit. The immediate result is that all subtargets are nuked, and any boards without dts files are no longer supported, though the target now includes more boards than before. The adc driver was also nuked as 3.8.7 includes a new one under the IIO subsystem. Signed-off-by: Adam Porter <porter.adam@gmail.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 36452
Diffstat (limited to 'target/linux/at91/9260')
-rw-r--r--target/linux/at91/9260/base-files/etc/config/network20
-rw-r--r--target/linux/at91/9260/base-files/etc/config/system9
-rw-r--r--target/linux/at91/9260/base-files/etc/init.d/custom-user-startup22
-rw-r--r--target/linux/at91/9260/config-default11
-rw-r--r--target/linux/at91/9260/profiles/000-flexibity-minimal.mk18
-rw-r--r--target/linux/at91/9260/profiles/001-flexibity-xwrt.mk26
-rw-r--r--target/linux/at91/9260/profiles/002-flexibity-luci.mk26
-rw-r--r--target/linux/at91/9260/target.mk16
8 files changed, 0 insertions, 148 deletions
diff --git a/target/linux/at91/9260/base-files/etc/config/network b/target/linux/at91/9260/base-files/etc/config/network
deleted file mode 100644
index 5800a0bffe..0000000000
--- a/target/linux/at91/9260/base-files/etc/config/network
+++ /dev/null
@@ -1,20 +0,0 @@
-
-config 'interface' 'loopback'
- option 'ifname' 'lo'
- option 'proto' 'static'
- option 'ipaddr' '127.0.0.1'
- option 'netmask' '255.0.0.0'
-
-config 'interface' 'cfg'
- option 'ifname' 'usb0'
- option 'proto' 'static'
- option 'netmask' '255.255.255.0'
- option 'gateway' '192.168.119.1'
- option 'ipaddr' '192.168.119.2'
-
-config 'interface' 'lan'
- option 'ifname' 'wlan0'
- option 'proto' 'dhcp'
-
-#config 'interface' 'wan'
-# option
diff --git a/target/linux/at91/9260/base-files/etc/config/system b/target/linux/at91/9260/base-files/etc/config/system
deleted file mode 100644
index ba7e87c629..0000000000
--- a/target/linux/at91/9260/base-files/etc/config/system
+++ /dev/null
@@ -1,9 +0,0 @@
-config 'system'
- option 'timezone' 'UTC'
- option 'hostname' 'flexibity'
-
-config timeserver ntp
- list server 0.openwrt.pool.ntp.org
- list server 1.openwrt.pool.ntp.org
- list server 2.openwrt.pool.ntp.org
- list server 3.openwrt.pool.ntp.org
diff --git a/target/linux/at91/9260/base-files/etc/init.d/custom-user-startup b/target/linux/at91/9260/base-files/etc/init.d/custom-user-startup
deleted file mode 100644
index dc9f77c98f..0000000000
--- a/target/linux/at91/9260/base-files/etc/init.d/custom-user-startup
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/sh /etc/rc.common
-START=90
-# place your own startup commands here
-#
-# REMEMBER: You *MUST* place an '&' after launching programs you
-# that are to continue running in the background.
-#
-# i.e.
-# BAD: upnpd
-# GOOD: upnpd &
-#
-# Failure to do this will result in the startup process halting
-# on this file and the diagnostic light remaining on (at least
-# for WRT54G(s) models).
-#
-
-# coldplug USB devices
-udevtrigger &
-
-# wait for coldplug and re-generate wireless config
-#wifi detect > /etc/config/wireless &
-
diff --git a/target/linux/at91/9260/config-default b/target/linux/at91/9260/config-default
deleted file mode 100644
index 5d19d063c7..0000000000
--- a/target/linux/at91/9260/config-default
+++ /dev/null
@@ -1,11 +0,0 @@
-CONFIG_ARCH_AT91SAM9260=y
-# CONFIG_MACH_AFEB9260 is not set
-# CONFIG_MACH_AT91SAM9260EK is not set
-# CONFIG_MACH_CAM60 is not set
-# CONFIG_MACH_CPU9260 is not set
-CONFIG_MACH_FLEXIBITY=y
-CONFIG_MACH_NO_WESTBRIDGE=y
-# CONFIG_MACH_QIL_A9260 is not set
-# CONFIG_MACH_SAM9_L9260 is not set
-# CONFIG_MACH_SNAPPER_9260 is not set
-# CONFIG_MACH_USB_A9260 is not set
diff --git a/target/linux/at91/9260/profiles/000-flexibity-minimal.mk b/target/linux/at91/9260/profiles/000-flexibity-minimal.mk
deleted file mode 100644
index f8e7a65143..0000000000
--- a/target/linux/at91/9260/profiles/000-flexibity-minimal.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 20011-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/flexibity-minimal
- NAME:=Flexibity Connect (minimal)
- PACKAGES:=
-endef
-
-define Profile/flexibity-minimal/Description
- Minimal packages set for the Flexibity Connect device.
-endef
-
-$(eval $(call Profile,flexibity-minimal))
-
diff --git a/target/linux/at91/9260/profiles/001-flexibity-xwrt.mk b/target/linux/at91/9260/profiles/001-flexibity-xwrt.mk
deleted file mode 100644
index fcd06999fd..0000000000
--- a/target/linux/at91/9260/profiles/001-flexibity-xwrt.mk
+++ /dev/null
@@ -1,26 +0,0 @@
-#
-# Copyright (C) 2011-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/flexibity-xwrt
- NAME:=Flexibity Connect (XWrt)
- PACKAGES:=bridge block-mount modprobe dnsmasq hotplug2 udev webif webif-applications webif-flexibity \
- syslog-ng sudo transmission-web miniupnpd nmap-ssl ip ntpclient ntpdate chat crda e169-stats genl hostapd-utils \
- iw madwimax netcat portmap ppp ppp-mod-pppoe pptp tcpdump usb-modem usb-modem-huawei-e175x usb-modem-huawei-eg162 \
- usb-modem-nokia-5800 wpa-cli wpa-supplicant motion badblocks blkid cifsmount disktype dosfsck dosfslabel e2fsprogs \
- fuse-utils mkdosfs nfs-utils ntfs-3g ntfs-3g-utils reiserfsprogs resize2fs sysfsutils tune2fs uuidgen certtool \
- gnutls-utils picocom setterm unrar unzip sqlite3-cli alsa-utils anyremote bluez-utils bzip2 comgt crypto-tools \
- file flock gdbserver gnupg gsm-utils gzip huaweiaktbbo hwclock i2c-tools input-utils ldd lsof mdadm \
- module-init-tools mount-utils openssl-util procps psmisc px5g screen strace stress sysstat uboot-envtools \
- usb-modeswitch usb-modeswitch-data usbutils lua
-endef
-
-define Profile/flexibity-xwrt/Description
- Complete packages set for the Flexibity Connect device (XWrt).
-endef
-
-$(eval $(call Profile,flexibity-xwrt))
-
diff --git a/target/linux/at91/9260/profiles/002-flexibity-luci.mk b/target/linux/at91/9260/profiles/002-flexibity-luci.mk
deleted file mode 100644
index 7985990014..0000000000
--- a/target/linux/at91/9260/profiles/002-flexibity-luci.mk
+++ /dev/null
@@ -1,26 +0,0 @@
-#
-# Copyright (C) 2011-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/flexibity-luci
- NAME:=Flexibity Connect (LuCI)
- PACKAGES:=bridge block-mount modprobe dnsmasq hotplug2 udev luci-flexibity \
- syslog-ng sudo transmission-web miniupnpd nmap-ssl ip ntpclient ntpdate chat crda e169-stats genl hostapd-utils \
- iw madwimax netcat portmap ppp ppp-mod-pppoe pptp tcpdump usb-modem usb-modem-huawei-e175x usb-modem-huawei-eg162 \
- usb-modem-nokia-5800 wpa-cli wpa-supplicant motion badblocks blkid cifsmount disktype dosfsck dosfslabel e2fsprogs \
- fuse-utils mkdosfs nfs-utils ntfs-3g ntfs-3g-utils reiserfsprogs resize2fs sysfsutils tune2fs uuidgen certtool \
- gnutls-utils picocom setterm unrar unzip sqlite3-cli alsa-utils anyremote bluez-utils bzip2 comgt crypto-tools \
- file flock gdbserver gnupg gsm-utils gzip huaweiaktbbo hwclock i2c-tools input-utils ldd lsof mdadm \
- module-init-tools mount-utils openssl-util procps psmisc px5g screen strace stress sysstat uboot-envtools \
- usb-modeswitch usb-modeswitch-data usbutils lua
-endef
-
-define Profile/flexibity-luci/Description
- Complete packages set for the Flexibity Connect device with LuCI.
-endef
-
-$(eval $(call Profile,flexibity-luci))
-
diff --git a/target/linux/at91/9260/target.mk b/target/linux/at91/9260/target.mk
deleted file mode 100644
index 91a1d75043..0000000000
--- a/target/linux/at91/9260/target.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2011 Flexibity
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-SUBTARGET:=9260
-BOARDNAME:=AT91SAM9260 Based board
-
-define Target/Description
- Build images for AT91SAM9260 based board, supported board:
- * Flexibity Connect
-endef
-