summaryrefslogtreecommitdiffstats
path: root/target/linux/aruba-2.6/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-05-20 18:51:23 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-05-20 18:51:23 +0000
commit07009a08e09829f777d6390cd35e2c25e4cbfb2c (patch)
tree919631bd2c2ec81c05d1af8585bf53dbd367249f /target/linux/aruba-2.6/image/Makefile
parentee1c03f7d650faca6c9ed6c0efed3e4f19def878 (diff)
downloadmaster-31e0f0ae-07009a08e09829f777d6390cd35e2c25e4cbfb2c.tar.gz
master-31e0f0ae-07009a08e09829f777d6390cd35e2c25e4cbfb2c.tar.bz2
master-31e0f0ae-07009a08e09829f777d6390cd35e2c25e4cbfb2c.zip
give Aruba some love - add support for the combined flash layout
SVN-Revision: 7283
Diffstat (limited to 'target/linux/aruba-2.6/image/Makefile')
-rw-r--r--target/linux/aruba-2.6/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/aruba-2.6/image/Makefile b/target/linux/aruba-2.6/image/Makefile
index e486b30ef2..7773f6a49e 100644
--- a/target/linux/aruba-2.6/image/Makefile
+++ b/target/linux/aruba-2.6/image/Makefile
@@ -31,11 +31,18 @@ define Image/BuildKernel
endef
define Image/Build/jffs2-64k
- @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=655360 conv=sync
+ @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=786432 conv=sync
@cat $(KDIR)/root.$(1) >> $(KDIR)/image.tmp
mv $(KDIR)/image.tmp $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(patsubst jffs2-%,jffs2,$(1)).bin
endef
+define Image/Build/squashfs
+ @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=786432 conv=sync
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ @cat $(KDIR)/root.$(1) >> $(KDIR)/image.tmp
+ @dd if=$(KDIR)/image.tmp of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin bs=64k conv=sync
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
endef