summaryrefslogtreecommitdiffstats
path: root/target/linux/arm64/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-11-24 06:34:07 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-11-24 06:34:07 +0000
commita2768bd9e0efb430e864fe5faf5070ea724e2797 (patch)
tree49fdd25cfab8faf7ab938fdd04da204fb43926cd /target/linux/arm64/Makefile
parentacf46919048fba514abf4d263e59e70eaddeb3ae (diff)
downloadmaster-31e0f0ae-a2768bd9e0efb430e864fe5faf5070ea724e2797.tar.gz
master-31e0f0ae-a2768bd9e0efb430e864fe5faf5070ea724e2797.tar.bz2
master-31e0f0ae-a2768bd9e0efb430e864fe5faf5070ea724e2797.zip
arm64: add ARM 64-bits target
This target can be emulated using ARM's Foundation_V8 simulator software or qemu-system-aarch64 using the command-line described in the README file. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 43355
Diffstat (limited to 'target/linux/arm64/Makefile')
-rw-r--r--target/linux/arm64/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/arm64/Makefile b/target/linux/arm64/Makefile
new file mode 100644
index 0000000000..a30430bb70
--- /dev/null
+++ b/target/linux/arm64/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=aarch64
+BOARD:=arm64
+BOARDNAME:=ARMv8 multiplatform
+FEATURES:=fpu ramdisk
+CFLAGS:=-Os -pipe -fno-caller-saves
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+KERNEL_PATCHVER:=3.14
+
+DEVICE_TYPE:=developerboard
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build multi-platform images for the ARMv8 instruction set architecture
+endef
+
+KERNELNAME:=Image dtbs
+
+$(eval $(call BuildTarget))